Page 3 of 3 FirstFirst 123
Results 21 to 26 of 26

Thread: Mesa 7.11 Release Candidate 1 Arrives

  1. #21

    Default

    Quote Originally Posted by ahlaht View Post
    It should be enough if your kernel has CONFIG_DEBUG_FS=y.
    Yes, the option is enabled.

  2. #22
    Join Date
    May 2011
    Posts
    58

    Default

    Quote Originally Posted by kraftman View Post
    then it doesn't work.
    Right. With only 1 power state the file is disabled. But you could still enable it if you wanted. Just move these 3 lines:

    Code:
    diff --git a/drivers/gpu/drm/radeon/radeon_pm.c b/drivers/gpu/drm/radeon/radeon_pm.c
    index aaa19dc..d3ef691 100644
    --- a/drivers/gpu/drm/radeon/radeon_pm.c
    +++ b/drivers/gpu/drm/radeon/radeon_pm.c
    @@ -608,6 +608,10 @@ int radeon_pm_init(struct radeon_device *rdev)
    
            INIT_DELAYED_WORK(&rdev->pm.dynpm_idle_work, radeon_dynpm_idle_work_handler);
    
    +       if (radeon_debugfs_pm_init(rdev)) {
    +               DRM_ERROR("Failed to register debugfs file for PM!\n");
    +       }
    +
            if (rdev->pm.num_power_states > 1) {
                    /* where's the best place to put these? */
                    ret = device_create_file(rdev->dev, &dev_attr_power_profile);
    @@ -621,10 +625,6 @@ int radeon_pm_init(struct radeon_device *rdev)
                    rdev->acpi_nb.notifier_call = radeon_acpi_event;
                    register_acpi_notifier(&rdev->acpi_nb);
     #endif
    -               if (radeon_debugfs_pm_init(rdev)) {
    -                       DRM_ERROR("Failed to register debugfs file for PM!\n");
    -               }
    -
                    DRM_INFO("radeon: power management initialized\n");
            }
    If you try this be prepared for a crash once you read the file, but I suspect it has been disabled unnecessarily.

  3. #23
    Join Date
    Sep 2010
    Location
    Lithuania
    Posts
    17

    Default can't compile r300g with latest LLVM!

    Hi,

    for a few weeks I can't compile r300g drivers, using latest LLVM 3.0 (2.9.99.svn20110711-32.1). At the end of compiling I've got error message like this:
    r300_dri.so.tmp: undefined reference to `LLVMAddTypeName'

    So, any patch or help!?

    Thanks.

  4. #24

    Default

    Quote Originally Posted by ahlaht View Post
    Right. With only 1 power state the file is disabled.
    Thanks, but it was easier than I thought. I had to change CPU scaling governor from ondemand to performance and OpenArena just flies.

  5. #25
    Join Date
    May 2011
    Posts
    58

    Default

    Quote Originally Posted by kraftman View Post
    Thanks, but it was easier than I thought. I had to change CPU scaling governor from ondemand to performance and OpenArena just flies.
    Thanks, that's very useful information. Just yesterday I noticed I may also have that problem. At least there is something shady about it. I didn't properly test it yet, because I also found some other bugs (sigh). I wonder if there is never end to these bugs...

  6. #26
    Join Date
    May 2010
    Posts
    681

    Default

    Does this have any good changes for intel graphics? (i'm running ironlake on arch linux, so I will probably get this not too long after it goes stable)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •