Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: NVIDIA Does An Official 275.xx Linux Driver Blob

  1. #1
    Join Date
    Jan 2007
    Posts
    14,654

    Default NVIDIA Does An Official 275.xx Linux Driver Blob

    Phoronix: NVIDIA Does An Official 275.xx Linux Driver Blob

    NVIDIA has officially introduced their 275.xx Linux driver series with the stable release of the 275.09.07 binary driver this morning...

    http://www.phoronix.com/vr.php?view=OTU2Nw

  2. #2
    Join Date
    Dec 2007
    Location
    Edinburgh, Scotland
    Posts
    575

    Default

    Does anyone know if this builds with the 3.0-rcX kernels without patches?

  3. #3
    Join Date
    May 2011
    Posts
    34

    Default

    While nvidia moves forward with supporting more and more new gpu's why don't they make the support of RandR in their proprietary driver? Or just make it possible to swap monitors without xorg restart...

    This is so annoying that each time i want to connect to external display I have to reload my session...

  4. #4
    Join Date
    Sep 2008
    Posts
    55

    Default

    Quote Originally Posted by FireBurn View Post
    Does anyone know if this builds with the 3.0-rcX kernels without patches?
    No Problems here

    Code:
    ~
    towo:Defiant> inxi -SG
    System:    Host Defiant Kernel 3.0.0-rc3.towo.1 x86_64 (64 bit) Distro sidux XFCE
    Graphics:  Card nVidia G94 [GeForce 9600 GT] X.Org 1.10.2 Res: 1920x1080@60.0hz                                                                                                              
               GLX Renderer GeForce 9600 GT/PCI/SSE2 GLX Version 3.3.0 NVIDIA 275.09.07

  5. #5
    Join Date
    Nov 2008
    Location
    Madison, WI, USA
    Posts
    865

    Default

    Does anyone know if this release also fixes the issues with Gnome-Shell + Nvidia when trying to enable multiple monitors?

    My GF9400M currently corrupts + locks every time I try to enable an external monitor in addition to my laptop's built-in LCD.

  6. #6
    Join Date
    Mar 2011
    Posts
    213

    Question Confused

    I'm running Ubuntu Natty and I have Nvidia driver version 270.41.06. Still update-manager tells me that there are no available updates.

    Wat do?

  7. #7
    Join Date
    Sep 2008
    Posts
    55

    Default

    Quote Originally Posted by M1kkko View Post
    I'm running Ubuntu Natty and I have Nvidia driver version 270.41.06. Still update-manager tells me that there are no available updates.

    Wat do?
    You know, that a driver release from nvidia has nothing to do with updates in your distro?
    Nvidia doesnt packaging drivers for any distro.

  8. #8
    Join Date
    May 2011
    Posts
    34

    Default

    If you want the latest video/xorg drivers add xorg-edgers ppa to your repos

  9. #9
    Join Date
    Mar 2011
    Posts
    213

    Smile

    Quote Originally Posted by kacperpl1 View Post
    If you want the latest video/xorg drivers add xorg-edgers ppa to your repos
    Sounds good, just the kind of thing I was looking for. But I was wondering if that repository is for the latest bleeding edge drivers or latest stable releases? (I'm looking for the latest stable Nvidia driver, as described in the news article)

  10. #10
    Join Date
    Oct 2010
    Posts
    93

    Default

    The latest stable releases are at https://launchpad.net/~ubuntu-x-swat/+archive/x-updates , but they don't have the new driver yet.

    If you really want to install these new drivers, you can download the individual DEB packages from the xorg-edgers PPA:

    32 bit:
    http://ppa.launchpad.net/xorg-edgers...natty_i386.deb
    http://ppa.launchpad.net/xorg-edgers...natty_i386.deb

    64 bit:
    http://ppa.launchpad.net/xorg-edgers...atty_amd64.deb
    http://ppa.launchpad.net/xorg-edgers...atty_amd64.deb

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •