Page 74 of 143 FirstFirst ... 2464727374757684124 ... LastLast
Results 731 to 740 of 1422

Thread: Updated and Optimized Ubuntu Free Graphics Drivers

  1. #731
    Join Date
    Nov 2013
    Posts
    3

    Default Oh Well....

    Quote Originally Posted by Dukenukemx View Post
    I've never tried to uninstall the drivers, but they do work fine for me on Mint 15.
    48 hours later i gave up..switched over to kubuntu now i am back to where i was, before mesa 10, everything working and i have open gl 3.0 and 60fps

    on a side note i did manage to downgrade the drivers to mesa 9.21xxx whatever, but while doing so, aptitude kept warning me about my kde libraries and such and how they were not meeting requirements for downgrading ??? anyway downgrading basically broke my kde desktop... i had to re-install kde-full, kde-plasma-workspaces, etc manually using aptitude, sort of worked, but my system was still using libvmpipe software gl renderer???

    so, know on to my third linux distro (kubuntu) in as many a months, thats one way to learn linux!

    Love this KDE desktop, so many options!

    L8

  2. #732
    Join Date
    Sep 2013
    Posts
    8

    Default Bonaire problems

    Hi again, following up on my last post. My 7790 with Mesa 10 does not have vdpau active. This is an up to date Saucy system wi.

    I've confirmed that I have all the relevant Oibaf packages up to date. vdpauinfo and glxinfo are firmly uninformative. e.g.
    e.g. $vdpauinfo
    display: :0.0 screen: 0
    Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file:

    $glxinfo
    name of display: :0.0
    Error: couldn't find RGB GLX visual or fbconfig
    Error: couldn't find RGB GLX visual or fbconfig

    Something is up with glamor:
    e.g. $Xorg.0.log | grep glamor ->
    [ 10.065] (II) LoadModule: "glamoregl"
    [ 10.120] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
    [ 10.335] (EE) Failed to load /usr/lib/xorg/modules/libglamoregl.so: /usr/lib/xorg/modules/libglamoregl.so: undefined symbol: _glapi_tls_Context
    [ 10.335] (II) UnloadModule: "glamoregl"
    [ 10.335] (II) Unloading glamoregl
    [ 10.335] (EE) Failed to load module "glamoregl" (loader failed, 7)
    [ 10.396] (WW) RADEON(0): glamor requires Load "glamoregl" in Section "Module", disabling.

    This might be a better look at it:
    $ cat /var/log/Xorg.0.log | grep EE
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [ 10.065] Initializing built-in extension MIT-SCREEN-SAVER
    [ 10.335] (EE) Failed to load /usr/lib/xorg/modules/libglamoregl.so: /usr/lib/xorg/modules/libglamoregl.so: undefined symbol: _glapi_tls_Context
    [ 10.335] (EE) Failed to load module "glamoregl" (loader failed, 7)
    [ 10.338] (EE) Failed to load /usr/lib/xorg/modules/extensions/libglx.so: /usr/lib/xorg/modules/extensions/libglx.so: undefined symbol: _glapi_tls_Context
    [ 10.338] (EE) Failed to load module "glx" (loader failed, 7)
    [ 10.339] (EE) Failed to load module "fglrx" (module does not exist, 0)
    [ 10.376] (EE) Failed to load module "fglrx" (module does not exist, 0)

  3. #733

    Default

    Thanks a lot for all your work with your ppa. I am wondering what happened to the vdpau support on 12.04. Few weeks ago it worked well, but for some time all I got was a white screen in xbmc. Is it going to be fixed?

  4. #734
    Join Date
    Nov 2013
    Posts
    5

    Default

    Hi , pretty much same question here about openGL 3.2 support for intel.
    I'm running mint 15 on a dell N5110 with nvidia and hd3000 (i915?) , my test base is fabric engine to see whether intel can be in a short time a good replacement for more expensive nvidia laptops.

    I've installed the ppa, and then done the dist-update.
    The driver seems installed properly as when I type glxinfo, this is what I get :

    OpenGL vendor string: Intel Open Source Technology Center
    OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Mobile
    OpenGL version string: 3.0 Mesa 10.0.0-devel (git-2f89662 raring-oibaf-ppa)
    OpenGL shading language version string: 1.30
    OpenGL context flags: (none)
    OpenGL extensions:


    The Version though seems fixed to 3.0 and this gets reported by fabric as well when I try to run a demo:
    [FABRIC:MT:Viewport_RenderSequenceDataDGNode:update RenderSequenceData] Disabling OpenGL rendering: Creation Platform requires at least OpenGL 3.2, and the curreng OpenGL version is 3.0 Mesa 10.0.0-devel (git-2f89662 raring-oibaf-ppa)

    I've been trying also to install the experimental one too, hoping for some improvements, but i can't see any /usr/lib/dri-alternates file or folder after installing them.

    If there's any more information I can provide just let me know , thanks.
    L.

  5. #735
    Join Date
    Aug 2012
    Posts
    70

    Default

    I feel some disturbance in the FORCE;;;


    "...
    AIGLX error: i965 exports no extensions (/usr/lib/x86_64-linux-gnu/dri/i965_dri.so: undefined symbol: __driDriverExtensions
    ...
    From latest oibaf and saucy repos...

  6. #736
    Join Date
    Apr 2013
    Posts
    221

    Default problem with glxinfo

    glxinfo not listed core profiles, i think is a error from glxinfo and not from drivers

  7. #737

    Default

    If you have an Intel and want OpenGL > 3.0 try updating to saucy and/or upgrading to a recent kernel (just a guess, no idea if it will work).

  8. #738
    Join Date
    Nov 2013
    Posts
    5

    Default

    Cheers Oibaf,
    here what I've got: Linux hdd-Inspiron-N5110 3.8.0-32-generic #47-Ubuntu SMP Tue Oct 1 22:35:23 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
    and mint 15 is based on 13.04 , which should fairly new. I'm just wondering whether I should expect to have GL 3.2 on the HD3000 or not.

    Grazie.
    L.

  9. #739

    Default

    @donquixote: try installing a 3.12 kernel.

  10. #740
    Join Date
    Nov 2013
    Posts
    5

    Default

    Thanks oibaf, I'll try to give it a go.
    Cheers!
    L.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •