Page 62 of 125 FirstFirst ... 1252606162636472112 ... LastLast
Results 611 to 620 of 1247

Thread: Updated and Optimized Ubuntu Free Graphics Drivers

  1. #611

    Default

    @Vincenzov: thanks, you should remove weston, I tried rebuilding it in my test PPA, but the version currently in Debian does not build with Wayland 1.2. As soon as an updated version will be released I'll backport it. Why do you installed it, BTW? EDIT: I suppose you installed it but there is no proof you did, indeed, you should try to see what package requires the 1.0.5 Wayland that prevents upgrading to 1.2.
    Last edited by oibaf; 09-17-2013 at 12:27 PM.

  2. #612
    Join Date
    Mar 2010
    Posts
    24

    Default

    I get the same error message... libgtk-3-0 seems to depend on it?

    Code:
    18:47  ~  $ LC_ALL=C sudo apt-get install -f
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Correcting dependencies... Done
    The following extra packages will be installed:
      libwayland-client0 libwayland-server0
    The following NEW packages will be installed:
      libwayland-client0 libwayland-server0
    0 upgraded, 2 newly installed, 0 to remove and 21 not upgraded.
    1 not fully installed or removed.
    Need to get 0 B/52.7 kB of archives.
    After this operation, 188 kB of additional disk space will be used.
    Do you want to continue [Y/n]? 
    (Reading database ... 187340 files and directories currently installed.)
    Unpacking libwayland-client0:amd64 (from .../libwayland-client0_1.2.1-1~r~gd_amd64.deb) ...
    dpkg: error processing /var/cache/apt/archives/libwayland-client0_1.2.1-1~r~gd_amd64.deb (--unpack):
     trying to overwrite '/usr/lib/x86_64-linux-gnu/libwayland-client.so.0.1.0', which is also in package libwayland0:amd64 1.0.5-0ubuntu1
    Unpacking libwayland-server0:amd64 (from .../libwayland-server0_1.2.1-1~r~gd_amd64.deb) ...
    dpkg: error processing /var/cache/apt/archives/libwayland-server0_1.2.1-1~r~gd_amd64.deb (--unpack):
     trying to overwrite '/usr/lib/x86_64-linux-gnu/libwayland-server.so.0', which is also in package libwayland0:amd64 1.0.5-0ubuntu1
    Errors were encountered while processing:
     /var/cache/apt/archives/libwayland-client0_1.2.1-1~r~gd_amd64.deb
     /var/cache/apt/archives/libwayland-server0_1.2.1-1~r~gd_amd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    
    18:47  ~  $ LC_ALL=C sudo apt-get remove libwayland0 libwayland-dev
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these:
    The following packages have unmet dependencies:
     libgbm1 : Depends: libwayland-client0 (>= 1.2.1) but it is not going to be installed
               Depends: libwayland-server0 (>= 1.2.1) but it is not going to be installed
     libgtk-3-0 : Depends: libwayland0 (>= 1.0.2) but it is not going to be installed
     libgtk-3-dev : Depends: libwayland-dev (>= 1.0.0) but it is not going to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

  3. #613
    Join Date
    Mar 2010
    Posts
    24

    Default

    Ah, I did a

    Code:
    sudo dpkg -i --force-overwrite /var/cache/apt/archives/libwayland-client0_1.2.1-1~r~gd_amd64.deb /var/cache/apt/archives/libwayland-server0_1.2.1-1~r~gd_amd64.deb
    sudo apt-get install -f
    sudo apt-get dist-upgrade
    sudo dpkg -i --force-overwrite /var/cache/apt/archives/libwayland-cursor0_1.2.1-1~r~gd_amd64.deb
    sudo apt-get dist-upgrade
    and it seems to install fine.

  4. #614
    Join Date
    May 2009
    Posts
    75

    Default

    The kde-window-manager package is the following (emphasis added), taken from Kubuntu backports (https://launchpad.net/~kubuntu-ppa/+archive/backports):

    Package: kde-window-manager
    Source: kde-workspace
    Priority: optional
    Section: x11
    Installed-Size: 5083
    Maintainer: Kubuntu Developers <kubuntu-devel@lists.ubuntu.com>
    Architecture: amd64
    Version: 4:4.11.1-0ubuntu1~ubuntu13.04~ppa2
    Replaces: kde-window-manager-common (<< 4:4.8.2a-0ubuntu2~), kde-window-manager-gles, kde-workspace-data (<< 4:4.8.4-0r5), kdebase-workspace-bin (<< 4:4.5.80), kdebase-workspace-data (<< 4:4.7.2)
    Suggests: weston
    Provides: x-window-manager
    Depends: libc6 (>= 2.14), libegl1-mesa (>= 7.8.1) | libegl1-x11, libegl1-mesa-drivers, libgl1-mesa-glx | libgl1, libgles2-mesa (>= 7.8.1) | libgles2, libice6 (>= 1:1.0.0), libkactivities6, libkdeclarative5, libkdecorations4abi1 (= 4:4.11.1-0ubuntu1~ubuntu13.04~ppa2), libkdecore5, libkdeui5, libkwineffects1abi4 (= 4:4.11.1-0ubuntu1~ubuntu13.04~ppa2), libkwinglesutils1 (= 4:4.11.1-0ubuntu1~ubuntu13.04~ppa2), libkwinglutils1abi2 (= 4:4.11.1-0ubuntu1~ubuntu13.04~ppa2), libplasma3, libqt4-dbus (>= 4:4.8.0), libqt4-declarative (>= 4:4.7.0~rc1), libqt4-script (>= 4:4.6.1), libqtcore4 (>= 4:4.8.0), libqtgui4 (>= 4:4.8.0), libsm6, libstdc++6 (>= 4.1.1), libwayland0 (>= 1.0.2), libx11-6, libx11-xcb1, libxcb-composite0, libxcb-damage0, libxcb-image0 (>= 0.3.9), libxcb-keysyms1 (>= 0.3.9), libxcb-randr0, libxcb-render0, libxcb-shape0, libxcb-shm0, libxcb-sync0, libxcb-xfixes0, libxcb-xtest0, libxcb1 (>= 1.6), libxcursor1 (>> 1.1.2), libxext6, libxrandr2 (>= 2:1.2.0), libxxf86vm1, kde-window-manager-common (= 4:4.11.1-0ubuntu1~ubuntu13.04~ppa2)
    Breaks: kde-style-bespin (<< 0.r1552-1+), kde-style-skulpture, kde-window-manager-common (<< 4:4.8.2a-0ubuntu2~), kde-window-manager-gles, kde-workspace-data (<< 4:4.8.4-0r5), kdeartwork-theme-window (<< 4:4.9.5), kdebase-workspace-bin (<< 4:4.5.80), kdebase-workspace-data (<< 4:4.7.2), kwin-style-crystal (<< 2.2.1), kwin-style-dekorator, kwin-style-qtcurve (<< 1.8.14-2+)
    Filename: pool/main/k/kde-workspace/kde-window-manager_4.11.1-0ubuntu1~ubuntu13.04~ppa2_amd64.deb
    Size: 1006008
    MD5sum: 91b805c2105accc3f0bc1e5c305934ef
    SHA1: 860b00bb65f5add6a35c1460c2b43c88e2976de6
    SHA256: c6b0e737ff0986f0251990c68a362a6967c98aee9b686f8b99 dd00110ab3c032
    Description: K window manager (KWin)
    This package contains KWin, the KDE window manager, featuring
    hardware-accelerated compositing effects.
    .
    This package is part of the KDE base workspace module.
    Original-Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>

    As for the output of apt-cache rdepends libwayland0 libwayland-client0 libwayland-server0 libwayland-dev libwayland-cursor0 libwayland0:

    jose@amdfx:~$ apt-cache rdepends libwayland0 libwayland-client0 libwayland-server0 libwayland-dev libwayland-cursor0 libwayland0
    Reverse Depends:
    libwayland-client0:i386
    libwayland-client0:i386
    libwayland-server0:i386
    libwayland-server0:i386
    libwayland-client0
    libwayland-client0
    libwayland-server0
    libwayland-server0
    kde-window-manager-active
    kde-window-manager
    libegl1-mesa-drivers
    libegl1-mesa
    libegl1-mesa-drivers
    libegl1-mesa
    libwayland0:i386
    libwayland0:i386
    weston
    libwayland0-dbg
    libwayland-dev
    libgtk-3-0
    libegl1-mesa-drivers
    libegl1-mesa
    libwayland-client0
    Reverse Depends:
    libgbm1
    libegl1-mesa
    libegl1-mesa-drivers
    libwayland-client0:i386
    libwayland-client0:i386
    libwayland-cursor0
    libwayland-client0-dbg
    libwayland-dev
    libgbm1
    libgtk-3-0
    libegl1-mesa-drivers
    libegl1-mesa
    libwayland-server0
    Reverse Depends:
    libgbm1
    libegl1-mesa
    libegl1-mesa-drivers
    libwayland-server0:i386
    libwayland-server0:i386
    libwayland-server0-dbg
    libwayland-dev
    libgbm1
    libegl1-mesa-drivers
    libegl1-mesa
    libwayland-dev
    Reverse Depends:
    libwayland-dev:i386
    libgtk-3-dev
    libwayland-dev:i386
    libgtk-3-dev
    libwayland-cursor0
    Reverse Depends:
    libwayland-cursor0:i386
    libwayland-cursor0:i386
    libwayland-cursor0-dbg
    libwayland-dev
    libgtk-3-0

  5. #615

    Default

    Quote Originally Posted by mudig View Post
    I get the same error message... libgtk-3-0 seems to depend on it?

    Code:
     libgbm1 : Depends: libwayland-client0 (>= 1.2.1) but it is not going to be installed
               Depends: libwayland-server0 (>= 1.2.1) but it is not going to be installed
     libgtk-3-0 : Depends: libwayland0 (>= 1.0.2) but it is not going to be installed
     libgtk-3-dev : Depends: libwayland-dev (>= 1.0.0) but it is not going to be installed
    .
    I updated yesterday gtk+3.0 packages, that should then depends on libwayland-client0, not libwayland0, probably you just did the update when the new wayland was built, but still not the updated gtk+3.0 packages. If someone has the same problem, should just do a sudo apt-get update and then dist-upgrade again.
    Last edited by oibaf; 09-18-2013 at 04:12 AM.

  6. #616

    Default

    @jsa1983

    Thanks, the updated kde-workspace packages are building now in a new PPA, see the notes I added at https://launchpad.net/~oibaf/+archive/graphics-drivers

    If they build fine (try in a hour) adding this PPA should make kde 4.11 properly work again. This will break again however if/when kubuntu PPA updates this package, so let me know and I'll do a rebuild again.

  7. #617
    Join Date
    May 2009
    Posts
    75

    Default

    Quote Originally Posted by oibaf View Post
    @jsa1983

    Thanks, the updated kde-workspace packages are building now in a new PPA, see the notes I added at https://launchpad.net/~oibaf/+archive/graphics-drivers

    If they build fine (try in a hour) adding this PPA should make kde 4.11 properly work again. This will break again however if/when kubuntu PPA updates this package, so let me know and I'll do a rebuild again.
    Thank you so much! KDE usually does minor point releases on a monthly basis. I will tell you when they get updated. In any case, I think I will try to open a bug in their bugtracker in order to suggest them a dependency on libwayland0 | libwayland-client0, which I think should solve the dependency problem.

    Regards

  8. #618

    Default

    Quote Originally Posted by jsa1983 View Post
    Thank you so much! KDE usually does minor point releases on a monthly basis. I will tell you when they get updated. In any case, I think I will try to open a bug in their bugtracker in order to suggest them a dependency on libwayland0 | libwayland-client0, which I think should solve the dependency problem.

    Regards
    The source package just depends on libwayland-dev, depending on the version the right package is used. I am not sure if it possible to use libwayland0 | libwayland-client0, but maybe it is.

  9. #619
    Join Date
    Oct 2011
    Location
    Italy
    Posts
    138

    Default

    Quote Originally Posted by mudig View Post
    Ah, I did a

    Code:
    sudo dpkg -i --force-overwrite /var/cache/apt/archives/libwayland-client0_1.2.1-1~r~gd_amd64.deb /var/cache/apt/archives/libwayland-server0_1.2.1-1~r~gd_amd64.deb
    sudo apt-get install -f
    sudo apt-get dist-upgrade
    sudo dpkg -i --force-overwrite /var/cache/apt/archives/libwayland-cursor0_1.2.1-1~r~gd_amd64.deb
    sudo apt-get dist-upgrade
    and it seems to install fine.
    Ok works good. thanks

  10. #620
    Join Date
    Oct 2011
    Location
    Italy
    Posts
    138

    Default

    Quote Originally Posted by Espionage724 View Post
    I use raring (Xubuntu), these drivers, and I'm on Norther Island hardware (7660G + 7670M). I also installed the xorg glamor package (and dependencies).

    Here's my xorg.conf:
    Code:
    Section "Module"
            Load "dri2"
            Load "glamoregl"
    EndSection
    
    Section "Device"
            Identifier "radeon"
            Driver "radeon"
            Option "AccelMethod" "glamor"
    EndSection
    And my Xorg.0.log: http://pastebin.com/raw.php?i=LQFfrqKF

    But after I reboot after setting my xorg.conf to use Glamor, I'm presented only with a black screen, with a mouse pointer on it. It's almost as if Xfce isn't loading fully or something.

    Just a quick question though about the Device section. Would I need to add another device section and somehow specify both devices in a dual graphics setup for glamor? Or does the Device section cover all devices?

    And also a general question; if I start 3D applications with DRI_PRIME=1 (my dGPU), they don't actually show anything at all if I have Xfce set to use no composting. If I enable composting though, the applications show up. Any ideas why, or what I could do to fix this (I don't want composting; I only want performance essentially)

    [ 22.728] (==) RADEON(0): Depth 24, (--) framebuffer bpp 32
    [ 22.728] (II) RADEON(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
    [ 22.728] (==) RADEON(0): Default visual is TrueColor
    [ 22.728] (**) RADEON(0): Option "AccelMethod" "glamor"
    [ 22.728] (==) RADEON(0): RGB weight 888
    [ 22.728] (II) RADEON(0): Using 8 bits per RGB (8 bit DAC)
    [ 22.728] (--) RADEON(0): Chipset: "CAICOS" (ChipID = 0x6779)
    [ 22.728] (II) Loading sub module "dri2"
    [ 22.728] (II) LoadModule: "dri2"
    [ 22.728] (II) Module "dri2" already built-in
    [ 22.728] (EE) RADEON(0): glamor requires Load "glamoregl" in Section "Module", disabling.
    [ 22.728] (II) Loading sub module "exa"

    hi, how enable glamor????

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •