Page 119 of 143 FirstFirst ... 1969109117118119120121129 ... LastLast
Results 1,181 to 1,190 of 1423

Thread: Updated and Optimized Ubuntu Free Graphics Drivers

  1. #1181

    Default intel gen 4-6 patch is out


  2. #1182
    Join Date
    Jul 2013
    Posts
    8

    Default

    Yup, bug has been resolved with 10.3~git1406100730.7a4527~gd~t.

  3. #1183

    Default

    I added llvm 3.4.2 to the 14.04 PPA, OpenGL 3.3 should be supported on more radeon cards now.

  4. #1184
    Join Date
    Jan 2013
    Posts
    53

    Default

    I use a 7870 (Pitcairn) with Xubuntu 14.04 and still stuck with GL3.1.

    Is it just not yet supported on my HW even with LLVM 3.4.2? Or can I somehow get it to run 3.3?

    Code:
    glxinfo |grep OpenGL
    OpenGL vendor string: X.Org
    OpenGL renderer string: Gallium 0.4 on AMD PITCAIRN
    OpenGL core profile version string: 3.1 (Core Profile) Mesa 10.3.0-devel
    OpenGL core profile shading language version string: 1.40
    OpenGL core profile context flags: (none)
    OpenGL core profile extensions:
    OpenGL version string: 3.0 Mesa 10.3.0-devel
    OpenGL shading language version string: 1.30
    OpenGL context flags: (none)
    OpenGL extensions:

  5. #1185

    Default

    Quote Originally Posted by Kraut View Post
    I use a 7870 (Pitcairn) with Xubuntu 14.04 and still stuck with GL3.1.

    Is it just not yet supported on my HW even with LLVM 3.4.2? Or can I somehow get it to run 3.3?

    Code:
    glxinfo |grep OpenGL
    OpenGL vendor string: X.Org
    OpenGL renderer string: Gallium 0.4 on AMD PITCAIRN
    OpenGL core profile version string: 3.1 (Core Profile) Mesa 10.3.0-devel
    OpenGL core profile shading language version string: 1.40
    OpenGL core profile context flags: (none)
    OpenGL core profile extensions:
    OpenGL version string: 3.0 Mesa 10.3.0-devel
    OpenGL shading language version string: 1.30
    OpenGL context flags: (none)
    OpenGL extensions:
    You didn't properly install the driver from the PPA. You should see something like (git-xxxxx trusty-oibaf-ppa) in the OpenGL vendor string.

  6. #1186
    Join Date
    Jan 2013
    Posts
    53

    Default

    Fount it! Was an xorg-edger ppa what wasn't removed cleanly.

    I shall feast in OpenGL features now!

  7. #1187
    Join Date
    Oct 2013
    Posts
    5

    Default

    Quote Originally Posted by oibaf View Post
    I added llvm 3.4.2 to the 14.04 PPA, OpenGL 3.3 should be supported on more radeon cards now.
    Thanks, much appreciated. Works for me.

    $glxinfo | grep OpenGL
    OpenGL vendor string: X.Org
    OpenGL renderer string: Gallium 0.4 on AMD PITCAIRN
    OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.3.0-devel (git-e974781 trusty-oibaf-ppa)
    OpenGL core profile shading language version string: 3.30
    OpenGL core profile context flags: (none)
    OpenGL core profile profile mask: core profile
    OpenGL core profile extensions:
    OpenGL version string: 3.0 Mesa 10.3.0-devel (git-e974781 trusty-oibaf-ppa)
    OpenGL shading language version string: 1.30
    OpenGL context flags: (none)
    OpenGL extensions:

  8. #1188
    Join Date
    Jun 2012
    Posts
    328

    Default

    Quote Originally Posted by oibaf View Post
    I added llvm 3.4.2 to the 14.04 PPA, OpenGL 3.3 should be supported on more radeon cards now.
    Woot, thanks! This one makes RadeonSI to support GL 3.3. Though when it comes to heavy 3D loads or OpenCL, it still full of bugs. But there is nothing more you can do about it I guess.

  9. #1189
    Join Date
    Mar 2014
    Posts
    21

    Default

    Quote Originally Posted by Kraut View Post
    Fount it! Was an xorg-edger ppa what wasn't removed cleanly.

    I shall feast in OpenGL features now!
    How did you find out? And how did you remove it cleanly? I have the same problem (glxinfo says I only have opengl 3.0 and no "oibaf" in the vendor line) and think a former xorg-edgers ppa could also be the cause. I already made a ppa-purge with xorg-edgers and oibaf, reinstalled oibaf ppa... but things still go wrong.

    For example I can't start steam with the oibaf ppa anymore. The system hardlocks instantly when I try to do this. Unigine valley also doesn't start anymore - not even overriding the opengl-version doesn't help here.

  10. #1190
    Join Date
    Jul 2014
    Posts
    1

    Default

    I've tried to use the PPA a few times these days but encountered a few issues with the current version of Mesa 10.3 (ATI RadeonHD 7770 GPU):
    - in XCOM Enemy Unknown a few days ago, random and complete system freeze (whith the game still running, with choppy sound and computer completely unresponsive − had to make a hard reset)
    - in Civilization V today, the game crashed randomly (might have been linked with the fact that Steam displayed a message for a trading card, as the crash happened just after)
    And a few problems of graphic garbage on the desktop and Steam interface, in specific zones. Also, the Firefox window completely trashed when opening a terminal window on Unity.

    It looks like the driver is quite unusable currently. Have people encountered similar bugs in games recently (the XCOM one was pretty naughty)?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •