Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 35

Thread: VBE Modesetting Dumps For Avivo R500 Driver

  1. #21
    Join Date
    Aug 2007
    Posts
    1

    Default

    Please find vbe dumps for an ATI X1300 Mobility (taken from an thinkpad) at the following url:

    http://www.digitalself.org/~phaethon...bedump.tar.bz2

    Cheers.

  2. #22
    Join Date
    Aug 2007
    Posts
    6

    Default

    Code:
    01:00.0 VGA compatible controller: ATI Technologies Inc RV530 [Radeon X1600] (prog-if 00 [VGA])
            Subsystem: PC Partner Limited Unknown device 0e10
            Flags: bus master, 66MHz, medium devsel, latency 255, IRQ 20
            Memory at a0000000 (32-bit, prefetchable) [size=256M]
            I/O ports at a800 [size=256]
            Memory at ff4f0000 (32-bit, non-prefetchable) [size=64K]
            Expansion ROM at ff4c0000 [disabled] [size=128K]
            Capabilities: <access denied>
    my vga AGP8x is Sapphire Radeon x1600 PRO HDMI / 256MB DDR2 Core 500Mhz Memory 396Mhz
    640x480
    800x600
    1024x768
    1280x1024

    http://www.file-upload.net/download-...py.tar.gz.html

  3. #23
    Join Date
    May 2007
    Posts
    233

    Default

    I have pushed code which program the TDMS like the BIOS does (at least on few dumps i did take a look at), so please if you did have any issue previously with DVI-I, laptop panel and avivo try it out.

  4. #24
    Join Date
    Jun 2007
    Posts
    6

    Default

    Thanks, those updates have addressed some banding weirdness I was seeing at 32bit colour depth (on a T60/X1400).

  5. #25
    Join Date
    May 2007
    Posts
    18

    Default

    that improved things a lot (t60 x1300 1024x768). Its almost useable. There is strange distortion (it looks like the screen is frying!.

    I tried to screen capture, but the capture shows a perfect image.

    below is a link to my vbe modesetting dumps - i am guessing the problem is that native res. of the laptop is 1024x768

    http://www.pirantech.co.uk/t60-m52-1024x768.tar.gz
    Last edited by danielpugh; 08-20-2007 at 06:19 PM.

  6. #26
    Join Date
    Aug 2007
    Posts
    3

    Post Results for Mobility FireGL V5200

    I have a native 1920x1200 display, however the BIOS does not seem to know that mode?!?

    Download my results from here.

    I put in all (8:8:8) Modes. However, when booting to single user mode vbetest keeps telling me to run it from the console?!?

    So, I booted with the avivo driver (latest version from today), switched to the console and got these results.

    Hope it helps, and thanx fore the nice work!

    butonic

  7. #27
    Join Date
    Aug 2007
    Posts
    4

  8. #28
    Join Date
    Aug 2007
    Posts
    3

    Default

    radeon x1950 xtx pcie dumpfiles

    http://mauss.dyndns.info/files/x1950xtx.tar

    thx & greets

  9. #29
    Join Date
    Aug 2007
    Location
    Norway
    Posts
    146

    Default Lenovo Thinkpad Z61m, ATI X1400

    Did vbetest on a Lenovo Thinkpad Z61m with an ATI X1400 in it.

    Could not find a mode corresponding to the native resolution of 1680x1050, but did the others.

    http://folk.uio.no/oyviste/vbetest

    Regards,
    oyvind

  10. #30
    Join Date
    Aug 2007
    Posts
    2

    Default

    Hi
    I'm running a T60 with X1400.

    Trying vbetest before fglrx or X loaded the test does not work, I see no colored screen and get the same result for all resolutions:

    http://www.file-upload.net/download-...50.txt.gz.html

    In the last line it says "To switch video modes, this program must be run from the console" though I was in console before loading fglrx or X.

    When switching from X with fglrx driver to console and using the tool with my native resolution 1400x1050:

    http://www.file-upload.net/download-...-X.txt.gz.html

    PS: The current avivio driver version (git from today) freezes my computer (first some color flicker, then black screen) so I have to hard reset.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •