Hi, I just tried to get the avivo driver working on what seems to be a X1250 (AMD 690G chipset on MSI K9AG Neo2-Digital).
I failed

My distro is Gentoo x86_64, kernel from kernel.org .

I got libpciaccess & xf86-video-avivo compiled and installed, but I still get the "no screens found" error.

Avivo module gets loaded correctly:
(II) LoadModule: "avivo"
(II) Loading /usr/lib64/xorg/modules/drivers//avivo_drv.so
(II) Module avivo: vendor="X.Org Foundation"
        compiled for 1.3.0, module version = 0.0.999
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 1.2
I updated xorg/avivo_chipset.c and include/avivo_chipset.h to match the new PCI ID (791e), but that doesn't help.
01:05.0 VGA compatible controller: ATI Technologies Inc Unknown device 791e (prog-if 00 [VGA])
        Subsystem: Micro-Star International Co., Ltd. Unknown device 7327
        Flags: bus master, fast devsel, latency 64, IRQ 10
        Memory at fc000000 (64-bit, prefetchable) [size=32M]
        Memory at fe9f0000 (64-bit, non-prefetchable) [size=64K]
        I/O ports at c000 [size=256]
        Memory at fe800000 (32-bit, non-prefetchable) [size=1M]
        Capabilities: [50] Power Management version 2
        Capabilities: [80] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
If anyone got a clue ... ;-)