Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: Turning green... FC6 + Ati Drivers 8.28.8...

  1. #11

    Default

    (EE) fglrx(0): [agp] unable to acquire AGP, error "xf86_ENODEV"
    (EE) fglrx(0): cannot init AGP

    Do you have any AGP options in your xorg.conf? If so change/remove them.

    (EE) AIGLX: Screen 0 is not DRI capable

    The fglrx drivers don't currently support AIGLX, so the Fedora desktop effects won't work.

  2. #12
    Join Date
    Nov 2006
    Posts
    8

    Question . . .

    yeah, I'am not after the effects.. just the DRI

    but now things, I think, have turned to the worse...

    I found that from one of my early "tests" I still had the Option "UseInternalAGPGART" "no" enabled in my xorg.conf and
    fixed that, but only to get this in my Xorg0.log


    Code:
    [...]
    
    (II) Loading sub module "fglrxdrm"
    (II) LoadModule: "fglrxdrm"
    (II) Reloading /usr/lib/xorg/modules/linux/libfglrxdrm.so
    (II) fglrx(0): Depth moves disabled by default
    (==) fglrx(0): Capabilities: 0x00000000
    (==) fglrx(0): CapabilitiesEx: 0x00000000
    (==) fglrx(0): cpuFlags: 0x8000001d
    (==) fglrx(0): cpuSpeedMHz: 0x00000ae9
    (WW) fglrx(0): DRI is not supported on Radeon 9000/9100 IGP (RS300/RS350) hardware.
    (==) fglrx(0): OpenGL ClientDriverName: "on_igp9x00_we_do_not_support_dri.so"
    
    [...]
    I have 9100 IGP...
    does this, for me, realy mean what it means?

    Last edited by phyx; 11-07-2006 at 09:36 PM.

  3. #13

    Default

    Whats your xorg.conf look like?

  4. #14
    Join Date
    Nov 2006
    Posts
    8

    Default Short and simple...

    my xorg.conf is very short and simple...

    Code:
    Section "ServerLayout"
    	Identifier     "Default Layout"
    	Screen      0  "Screen0" 0 0
    	InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "Module"
    	Load  "dri"
    	Load  "glx"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Keyboard0"
    	Driver      "kbd"
    	Option	    "XkbModel" "pc105"
    	Option	    "XkbLayout" "is"
    EndSection
    
    Section "Monitor"
    	Identifier   "monitor0"
    	VendorName   "MEDION"
    	ModelName    "27LCD"
    	HorizSync    47.7 - 47.7
    	VertRefresh  60.0 - 60.0
    	Option	    "DPMS" "true"
    EndSection
    
    Section "Device"
    
    	Identifier  "Videocard0"
    	Driver      "fglrx"
    
    EndSection
    
    Section "Extensions"
    	Option "Composite" "Disable"
    EndSection
    
    Section "Screen"
    	Identifier "Screen0"
    	Device     "Videocard0"
    	Monitor    "monitor0"
    	DefaultDepth     24
    
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    		Modes	"1024x768"
    	EndSubSection
    EndSection

  5. #15

    Default

    Something just hit me I don't know why I didn't mention this before... Are you using the 8.30 drivers or the 8.28 legacy drivers (with the script available at redblog)? Support for the Radeon 9100 was dropped in 8.28.8. If you're using the 8.30.8, try http://www.phoronix.com/redblog/?p=blog&i=NTg1MA (Sorry if you mentioned this before)

  6. #16
    Join Date
    Nov 2006
    Posts
    8

    Default

    yes, I'am using the 8.28.8 drivers (on FC6) because of this 'discontinued' support, post v8.28.8, for the Radeon 9000 / 9100 / 9200 chips...

  7. #17

    Default

    I'll see if I can replicate this issue with your configuration using a Radeon 9200. I haven't run into this problem (at least recently that I remember), but I don't deal with R200 stuff too often these days.

    Did you happen to check the Bugzilla?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •