Hello Phoronix,

I think I have a big problem here. Namely, my old HDD on the Acer Aspire 5710Z died a week or two ago so I bought a replacement Toshiba 320GB 1 week ago and tried installing Win7 & later Ubuntu 10.04 on it, but without any use.

The W7 installation progressed up until about 99% by going 1% up for 5 minutes (so it took ~5hrs until it reached 99%) when it hung. I canceled the installation, I put in U10.04 and used testdisk to restore the MBR and removed the NTFS partition of Win7. Ubuntu couldn't even create a partition afterwards, I tried installing it and it hung at 5% when it was creating the Ext4 partition. I left it like that for a whole night and went to bed; the next morning the situation was the same.

So I returned the HDD and got my money back and bought a Western Digital 320GB 2 days ago. On this one Win7 didn't even go above 1% and spawn an error, so I used testdisk again to restore the MBR and install Ubuntu, but to no avail.

This time instead of using Ubuntu I tried creating my own partitions using gparted, but everytime I did that I got an error and afterwards the HDD disappeared from gparted or palimpset. Fixing it with testdisk appeared to have fixed it, because it did appear in gparted again, but every following attempt to partition it failed.

And now, the HDD doesn't even show up in either and because of that I can't restore the MBR or do anything to it, even though it does appear in the BIOS.

So what should I do? Return this HDD too? Is the jumper on my motherboard what's corrupting the hard disks (or another hw problem), is it a software problem or am I doing something horribly wrong that messes up everything?

I'll be so glad to receive an answer, any answer :)