Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: How do you disable direct2d acceleration method?

  1. #1
    Join Date
    May 2007
    Posts
    352

    Default How do you disable direct2d acceleration method?

    I'd like to revert to XAA because direct2d just seems to be too buggy:

    http://68.45.22.62/thunderbird.jpg

    See the folder list? Sometimes it's that gray color, sometimes it's black, sometimes it's white, and sometimes it displays just fine. This isn't just limited to the folder list. It happens with the message list and the message pane itself.

    However, this command:

    # aticonfig --del-pcs-key=DDX,Direct2DAccel

    Doesn't seem to do it. Even after running that and restarting X, the log file still shows:

    (==) fglrx(0): ATI 2D Acceleration Architecture enabled

    Any ideas how I can disable this till all the kinks have been worked out? Anyone else think it was made the default too soon?

    Adam

  2. #2
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,386

    Default

    The option name to disable is something like ForceXAA - might be in the aticonfig -help output, not sure.

  3. #3
    Join Date
    May 2007
    Posts
    352

    Default

    XAA doesn't show up in the 'aticonfig --help' output. Just in case, I tried 'aticonfig --forcexaa' and 'aticonfig --ForceXAA' but aticonfig just gave an error that it was an unrecognized option.

  4. #4
    Join Date
    May 2007
    Posts
    352

    Default

    Also, I'm not seeing an option for it in amdcccle, nor does anything about XAA show up in any of the documents in /usr/share/doc/fglrx

  5. #5
    Join Date
    May 2007
    Posts
    352

    Default

    Also, interestingly enough, the problem doesn't happen if I enable a compositing manager (compiz or xcompmgr).

    Adam

  6. #6
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,386

    Default

    Try something like :

    aticonfig --set-pcs-str=DDX,ForceXAA,TRUE

  7. #7
    Join Date
    May 2007
    Posts
    352

    Default

    That did it...

    (--) fglrx(0): ATI 2D Acceleration Architecture disabled, using XAA

    And now thunderbird looks just fine.

    Should I file this as a bug report somewhere?

    Adam

  8. #8
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,386

    Default

    Yes please; ati.cchtml.com would be ideal. Mentioning that the problem only appears with compositing off would be very helpful...

    Thanks !

  9. #9
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,386

    Default

    Also the devs asked me to pass along that the Cat 10.6 drivers aren't ready for old vs new benchmarking yet, ie we enabled the new accel code by default as soon as it appeared the stability was there, we didn't wait for performance optimization.

  10. #10
    Join Date
    Nov 2008
    Location
    Germany
    Posts
    5,411

    Default

    Quote Originally Posted by bridgman View Post
    Also the devs asked me to pass along that the Cat 10.6 drivers aren't ready for old vs new benchmarking yet, ie we enabled the new accel code by default as soon as it appeared the stability was there, we didn't wait for performance optimization.
    "we didn't wait for performance optimization. "

    10-6 is the fastest catalyst ever... wait for performance optimization's is like waiting for the Jewish Messiah......

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •