Results 1 to 10 of 10

Thread: Mac v Windows v Ubuntu 10.04 Benchmarks - do you turn off compiz ? Also arch results

  1. #1
    Join Date
    Sep 2007
    Posts
    36

    Default Mac v Windows v Ubuntu 10.04 Benchmarks - do you turn off compiz ? Also arch results

    Hi.

    There is 1 important thing I would like to know regarding the benchmarks.

    When you run the 3D tests did you disable compiz?

    I ask because on my machine it reduces in game FPS by about 30-40%

    Also, seeing as in past tests Arch linux was about 10-20% faster in some of your bechmarks would that not have equalled Windows 7 in some of the tests ?

    I did post this in the thread but had no direct response.

  2. #2
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,791

    Default

    Then you'd have to disable Aero on 7 and whatever-it's-called on OS X too

  3. #3
    Join Date
    Sep 2007
    Posts
    36

    Default

    Well this is sort of the point.

    As far as i'm aware (correct me if I am wrong) in Winblows7 Aero is automatically disabled when running full screen 3D.

    If that is the case then a re-test with compiz disabled would be more fair (that is if compiz wasn't disabled in the 1st place) (the results would be more similar)

    I create a script that I load when playing a game that disabled compiz (and get roughly 30-40% more fps)

    This is what Linux lacks - There needs to be a way of automatically disabling compiz when running 3d games (whats the point of running compiz when you can't see it?) - there is a brainstorm idea here

    http://brainstorm.ubuntu.com/idea/12737/

    In my experience every game that co-exists for linux and windows is faster in linux on Nvidia hardware - i.e etqw, et, savage, prey, nexuiz, openarea - i always disable compiz. Not only more fps but more responsive also (bfs kernel makes this more so)

  4. #4

    Default

    Each OS was left with their default settings. Ubuntu enables Compiz by default when running the NVIDIA driver.

  5. #5
    Join Date
    May 2007
    Location
    Third Rock from the Sun
    Posts
    6,584

    Default

    Quote Originally Posted by yossarianuk View Post
    This is what Linux lacks - There needs to be a way of automatically disabling compiz when running 3d games (whats the point of running compiz when you can't see it?) - there is a brainstorm idea here
    Not really, KDE 4 Compositor is automatically disabled as well when running 3d games fullscreen. This is a Gnome/Compiz issue.

  6. #6

    Default

    Quote Originally Posted by Michael View Post
    Each OS was left with their default settings. Ubuntu enables Compiz by default when running the NVIDIA driver.
    Then it seems a compiz slowed Ubuntu down in graphics

  7. #7

    Default

    Quote Originally Posted by deanjo View Post
    Not really, KDE 4 Compositor is automatically disabled as well when running 3d games fullscreen. This is a Gnome/Compiz issue.
    Maybe it should in theory. When I have kwin effects enabled I have about half FPS less in games. Kubuntu 10.04.

  8. #8
    Join Date
    May 2007
    Location
    Third Rock from the Sun
    Posts
    6,584

    Default

    Quote Originally Posted by kraftman View Post
    Maybe it should in theory. When I have kwin effects enabled I have about half FPS less in games. Kubuntu 10.04.
    Works here every time using the nvidia blobs.

  9. #9

    Default

    Quote Originally Posted by deanjo View Post
    Works here every time using the nvidia blobs.
    So it doesn't work with OSS Radeon driver.

  10. #10
    Join Date
    May 2007
    Location
    Third Rock from the Sun
    Posts
    6,584

    Default

    Quote Originally Posted by kraftman View Post
    So it doesn't work with OSS Radeon driver.
    That's not surprising.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •