Results 1 to 5 of 5

Thread: Toggle GUI/CLI?

  1. #1
    Join Date
    Apr 2010
    Posts
    3

    Default Toggle GUI/CLI?

    Is there any way to not use the GUI? Running any command over ssh, e.g. "phoronix-test-suite --help" or "phoronix-test-suite run iozone" always results in the same error:

    PHP Fatal error: php-gtk: Could not open display in Unknown on line 0
    Could not startup.

    As long as X is running in the current session(either at the console or via nx,) everything works great, but always through the GUI. This could very well be a configuration problem with php/php-gtk on this box. I did a bit of searching in these forums and elsewhere but haven't had any luck. Thank you in advance!

  2. #2
    Join Date
    Apr 2010
    Posts
    3

    Default

    Correction: if X is running I DO have the option of not using the GUI. Over ssh, however, php-gtk cannot detect a running Xserver for the session and throws the above error.

  3. #3

    Default

    The only time that PHP-GTK should ever be called is if using "phoronix-test-suite gui". If you run "phoronix-test-suite benchmark <test>" from a CLI or remote SSH it should work on the CLI as expected.

  4. #4
    Join Date
    Apr 2010
    Posts
    3

    Default

    Thank you for responding so quickly. Would you happen to know where the mis-configuration has occurred? php.ini? I'm using Arch Linux and installed PTS following these instructions: http://wiki.archlinux.org/index.php/...nix_Test_Suite

  5. #5

    Default

    If you are running "phoronix-test-suite help" there really isn't a possible way for the GUI to try to be initialized... Are you sure you are typing the command correctly?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •