Page 8 of 8 FirstFirst ... 678
Results 71 to 75 of 75

Thread: Adobe's Linux Video API Rant Extended

  1. #71
    Join Date
    Jun 2006
    Posts
    358

    Default

    /offtopic: and this http://4front-tech.com/hannublog/?p=36 sounds good

    @Michael: do make that post EDIT time limit bigger than 1 minute pleasa

  2. #72
    Join Date
    Oct 2007
    Location
    Under the bridge
    Posts
    2,146

    Default

    Quote Originally Posted by Licaon View Post
    /offtopic: i'm now a happy OSSv4 user since i tested it a while ago, i love to listen to glitch free music with MPD, while i don't have anything against ALSA per se, i can't be happy with skipping music when my CPU is at 50% or when i copy some files from a partition to another
    oh, and this ( need for ALSA ) situation was created by 4 Front when they decided to stop support those kernel drivers so i kinda hate them for that but love them for what OSSv4 is now ( a viable alternative to my ALSA gripes )
    I read somewhere that OSSv4 does not support suspend-to-ram (sleep) - is this true?

  3. #73
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,798

    Default

    It's true. Suspend doesn't work with OSS4. One has to close all applications that use it and do a "soundoff" before suspending.

  4. #74
    Join Date
    Oct 2007
    Location
    Under the bridge
    Posts
    2,146

    Default

    Thanks, I just read that Licaon's link which suggests proper power management as one of the goals for OSSv5. Pretty nasty as it is, OSSv4 cannot really replace ALSA+Pulse without proper suspend, at least not in the general case. I guess it could work for some people, but I'd be really pissed if my laptop couldn't go to sleep!

    No, wait, Nvidia managed to break suspend pretty well here. And, ugh, it sucks. Whoever says that fast boots aren't necessary is an idiot!

    And I think I'm ranting again, logging off.

  5. #75
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,798

    Default

    Personally, I could continue living with this issue if it means I can keep having acceptable audio latencies, non-skippy audio and a "dmix" (vmix in OSS4) that actually works. But in the end, as I see it, only a two things can help:

    * Someone fixes ALSA (unlikely)
    * Someone fixes OSS4 (unlikely)
    * Someone kills ALSA so development shifts to OSS4 (unlikely)

    So I guess Linux audio is still screwed for years to come :P

    Note that fixing PulseAudio doesn't help; it uses either ALSA or OSS under the hood, and it's those that are broken (with ALSA being more broken when I judge it using my own priorities.)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •