Page 116 of 117 FirstFirst ... 1666106114115116117 LastLast
Results 1,151 to 1,160 of 1167

Thread: AMD's UVD2-based XvBA Finally Does Something On Linux

  1. #1151
    Join Date
    Jan 2011
    Posts
    4

    Default never mind

    ok never mind, I finally got it working. Using xbmc with vaapi acceleration. the image is very distorted though, is this to be expected?

  2. #1152
    Join Date
    Jan 2011
    Posts
    4

    Default

    Quote Originally Posted by ludovicrl View Post
    ok never mind, I finally got it working. Using xbmc with vaapi acceleration. the image is very distorted though, is this to be expected?
    ok I fixed the distorted image by using catalyst 10.12. The picture is now very clear. It is working perfectly in mplayer with vaapi but it is stuttering a lot in xbmc. dunno how to fix this?

  3. #1153
    Join Date
    Jan 2011
    Posts
    4

    Default

    Quote Originally Posted by ludovicrl View Post
    ok I fixed the distorted image by using catalyst 10.12. The picture is now very clear. It is working perfectly in mplayer with vaapi but it is stuttering a lot in xbmc. dunno how to fix this?
    ok could fix this with a patch to xbmc:
    wget http://trac.xbmc.org/raw-attachment/...ce_reuse.patch
    patch -p0 vaapi_surface_reuse.patch

  4. #1154
    Join Date
    Jan 2011
    Posts
    2

    Default

    Quote Originally Posted by DanL View Post
    You have to install the libva(-dev) from SDS and rebuild mplayer-vaapi or vlc against that. Some heavy lifting has already been done for you: http://wiki.cchtml.com/index.php/Ubu...XPERIMENTAL.29
    thanks for the reply! so, i used the PPA that's mentioned in the wiki you linked, and installed libva and vlc from it, with the xvba-backend from the splitted desktops site. it works fine on "ordinary" movies, but when i try an HD movie it just freezes the computer completely. i have to switch it off. this happened in my previous attempts too (i've managed to install the libva from the splitted desktops site, and compile the mplayer given there, to get the same freeze effect).

    the wiki says that UVD support was broken in the new Catalyst drivers and that 10.7 is the last version of the drivers that works on non-UVD2 cards. i have a mobility radeon HD 3470, that's just UVD+, so that might be the case for me too?

    i've downloaded Catalyst 10.7, but the installer just crashes when started without args. i managed to build packages for maverick, and installed them, but X would no longer start after rebooting. what can i do now?..

  5. #1155
    Join Date
    Dec 2010
    Location
    NL
    Posts
    6

    Default

    Quote Originally Posted by ludovicrl View Post
    ok could fix this with a patch to xbmc:
    wget http://trac.xbmc.org/raw-attachment/...ce_reuse.patch
    patch -p0 vaapi_surface_reuse.patch
    Thanks! This solved all problems that - I thought- had to do with not fully matured VAAPI support on AMD's side (never bothered to look if it had anything to do with XBMC).

    I used:
    Catalyst 11.1
    And from gbeauche:
    libva1_0.31.1-1+sds5 (dated 26 jan 2011)
    xvba-video_0.7.8.pre1-1 (dated 26 jan 2011)

    Everything plays very smoothly with full HW acceleration now .

    But I noticed a few things that I would've hoped to have been solved by now:

    Sometimes switching to (and from) movies in xbmc there is garbled output for a (very) short moment. Sometimes just before the movie starts, sometimes after quitting a movie and returning to the xbmc interface. Also sometimes starting xbmc from within Ubuntu. Could this this be related to resolution changes, as I think I've read somewhere on the xbmc forum?

    And also:
    I have a HD5550 card, that supports UVD 2.2. Now it could be me but I believe that UVD 2.x supports MPEG2 HW acceleration?



    But nope, it is not there:



    And indeed, upon checking:

    Code:
    vainfo: VA API version: 0.31
    vainfo: Driver version: Splitted-Desktop Systems XvBA backend for VA-API - 0.7.8.pre1
    vainfo: Supported profile and entrypoints
          VAProfileH264High               :	VAEntrypointVLD
          VAProfileVC1Advanced            :	VAEntrypointVLD
    Is this normal? Or is it still on its way?

    In summary I see VAAPI support almost as usable now under XBMC (except for the resolution switch problem, at least that seems to be the problem -as I seem to understand- related to the short garbled moments I see, on swithing between content and GUI).

  6. #1156
    Join Date
    Aug 2007
    Posts
    6,688

    Default

    Mpeg2 is only accellerated with Intel or Nvidia.

  7. #1157
    Join Date
    Nov 2009
    Posts
    101

    Default

    Quote Originally Posted by ludovicrl View Post
    ok could fix this with a patch to xbmc:
    wget http://trac.xbmc.org/raw-attachment/...ce_reuse.patch
    patch -p0 vaapi_surface_reuse.patch
    Likes to crash a lot on exiting/reentering xbmc though.

  8. #1158

    Default

    I am planning to buy a zacate motherboard with E-350 for a HTCP. I would like to know if the hardware acceleration works and how well (especially with mythtv). It seems that mythtv will support vaapi in the future 0.25, but would I be able to use it now if I patch/compile? Also is the hardware acceleration as a good as nivdia ion?

  9. #1159
    Join Date
    Nov 2009
    Posts
    101

    Default

    I see the point of that, Zacate Hardware is very nice, but if you want a stable HTPC on linux, run (to nvidia) while you can.

  10. #1160
    Join Date
    Dec 2010
    Posts
    4

    Default

    if i can ask a quick noob question...been waiting to get into linux after i upgraded my comp but for now i have a 3850 and i have been holding out on learning the linux world until i can play hw accelerated movies on my system has there been any changes in this years drivers yet i not sure i understand the previous few pages of posts, and im not sure i wont to devote the time to yet if its still not available for my card..has there been progress or should i still wait to my funds are up..thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •