Page 5 of 7 FirstFirst ... 34567 LastLast
Results 41 to 50 of 69

Thread: ATI R600/700 3D Support In Fedora 12

  1. #41
    Join Date
    Jul 2007
    Posts
    448

    Default Interesting - I also have a Radeon with Audigy2 combination

    Quote Originally Posted by AdamW View Post
    blindfrog: did you file a bug for that?

    There was another guy having odd interactions between radeon driver and his sound card. I wonder if there's something deeper going on than just resource conflicts...
    And then there's me:

    http://phoronix.com/forums/showthrea...7468#post97468

    I have a Radeon 9550, and am running a 2.6.31.5 kernel with Fedora 11 and without KMS. And although I say "suddenly", it would be more accurate to say that things have suddenly become a lot worse. My "noise" problem used to only happen for a minute or so after start-up, and would then go away.
    Last edited by chrisr; 10-28-2009 at 06:22 AM.

  2. #42

    Default

    Quote Originally Posted by chrisr View Post
    And then there's me:

    http://phoronix.com/forums/showthrea...7468#post97468

    I have a Radeon 9550, and am running a 2.6.31.5 kernel with Fedora 11 and without KMS. And although I say "suddenly", it would be more accurate to say that things have suddenly become a lot worse. My "noise" problem used to only happen for a minute or so after start-up, and would then go away.
    Interesting, but not the same problem. I'd have a tough time guessing what your problem actually is, though. Try moving your Audigy to a different PCI slot, if it's an expansion card and not on-board.

  3. #43
    Join Date
    Oct 2009
    Posts
    2

    Default

    > If it doesn't load r600 it will default to swrast.

    could you post me your output of:
    glxinfo |grep -E 'OpenGL|server|client'
    ?

  4. #44
    Join Date
    Oct 2009
    Posts
    1

    Default

    Quote Originally Posted by iVistux View Post
    Are there any experiences with Radeon3D and KDE4 (Kwin)??

    Btw. if someone successfully tests games, drop it here: http://www.x.org/wiki/RadeonProgram
    I tried it in the current Fedora 12 Beta and it .. started. There were some minor glitches (like wrong transparency) and the performance was so medium. My gfx card is a radeon 4830.

  5. #45
    Join Date
    Jun 2009
    Posts
    4

    Default Radeon X800?

    I'd like to know whether my Power Mac G5's Radeon x800 will be working under Fedora 12? It wasn't with 11.

  6. #46
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,544

    Default

    Is there an active bug ticket open for the problem ? If not, there's a good chance nobody is aware something needs to be done.

  7. #47
    Join Date
    Oct 2009
    Posts
    2,138

    Default

    Quote Originally Posted by ewood View Post
    I'd like to know whether my Power Mac G5's Radeon x800 will be working under Fedora 12? It wasn't with 11.
    Right... x800 should have been working since F...9?
    As bridgman above says, might be a bug that just doesn't happen to be known, i.e., it doesn't affect very many people. Be sure to report it, i.e. to the bug trackers of both Fedora as well as Xorg.

    Could also be something to do with the KMS stuff that was really in a "not sure if its coming or going" state in F11, might want to try to just force-disable KMS. I think the kernel parameter is "nomodeset" (or something like that).

    Might also help if you describe what it does (or does not) do in more details... "not working" doesn't give anybody much to go on.

  8. #48
    Join Date
    Oct 2007
    Posts
    1,311

    Default

    Quote Originally Posted by dernob View Post
    and the performance was so medium...
    Aren't Fedora pre-releases built with debugging code? That could slow it down..

  9. #49
    Join Date
    Dec 2007
    Posts
    2,402

    Default

    Quote Originally Posted by ewood View Post
    I'd like to know whether my Power Mac G5's Radeon x800 will be working under Fedora 12? It wasn't with 11.
    KMS was missing big endian support when F11 was released. It should be working now, although it gets less testing than x86.

  10. #50

    Default

    DanL: the kernel from F12 Beta still had debugging code built-in, the latest one from updates does not. Testing indicates a noticeable performance improvement for Radeon/KMS with the non-debug kernel.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •