Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: 1920x1080 @ 60Hz not working

  1. #1
    Join Date
    Dec 2009
    Posts
    17

    Default 1920x1080 @ 60Hz not working

    Hi guys,
    I'm new to this forum and already asking so many questions. Hope you don't mind.

    I've a Nvidia GTS 8800 PCIE on an Asrock Dual SataII connected to a Sharp Aquos 32" LCD TV. I tried open source nouveau drivers and nvidia proprietary drivers. However I can get this tv to work at 1980x1080@60Hz, currently I run it at 50Hz. In the settings I only can select 50..56Hz. Even trying to force it by xorg.conf does not work, still 50Hz.
    By the way, I use Fedora 12 x86_64.

    Does anyone have a clue?
    Thanks!

  2. #2
    Join Date
    Aug 2007
    Posts
    6,641

    Default

    The reason will be in the edid, check /var/log/Xorg.0.log. If you would know what to do you can override every setting which is blocking that res/refresh.

  3. #3
    Join Date
    Dec 2009
    Posts
    17

    Default

    Hi,
    thanks for your reply.
    Here form my Xorg.0.log:
    Code:
    (II) Mar 28 20:29:08 NVIDIA(0): NVIDIA GPU GeForce 8800 GTS 512 (G92) at PCI:1:0:0 (GPU-0)
    (--) Mar 28 20:29:08 NVIDIA(0): Memory: 524288 kBytes
    (--) Mar 28 20:29:08 NVIDIA(0): VideoBIOS: 62.92.25.00.05
    (II) Mar 28 20:29:08 NVIDIA(0): Detected PCI Express Link width: 16X
    (--) Mar 28 20:29:08 NVIDIA(0): Interlaced video modes are supported on this GPU
    (--) Mar 28 20:29:08 NVIDIA(0): Connected display device(s) on GeForce 8800 GTS 512 at
    (--) Mar 28 20:29:08 NVIDIA(0):     PCI:1:0:0:
    (--) Mar 28 20:29:08 NVIDIA(0):     Samsung SyncMaster (CRT-1)
    (--) Mar 28 20:29:08 NVIDIA(0):     SHARP HDMI (DFP-0)
    (--) Mar 28 20:29:08 NVIDIA(0): Samsung SyncMaster (CRT-1): 400.0 MHz maximum pixel clock
    (--) Mar 28 20:29:08 NVIDIA(0): SHARP HDMI (DFP-0): 330.0 MHz maximum pixel clock
    (--) Mar 28 20:29:08 NVIDIA(0): SHARP HDMI (DFP-0): Internal Dual Link TMDS
    (II) Mar 28 20:29:08 NVIDIA(0): Display Device found referenced in MetaMode: DFP-0
    (WW) Mar 28 20:29:08 NVIDIA(0): The EDID for SHARP HDMI (DFP-0) contradicts itself: mode
    (WW) Mar 28 20:29:08 NVIDIA(0):     "1920x1080" is specified in the EDID; however, the EDID's
    (WW) Mar 28 20:29:08 NVIDIA(0):     valid VertRefresh range (49.000-76.000 Hz) would exclude
    (WW) Mar 28 20:29:08 NVIDIA(0):     this mode's VertRefresh (24.0 Hz); ignoring VertRefresh
    (WW) Mar 28 20:29:08 NVIDIA(0):     check for mode "1920x1080".
    (WW) Mar 28 20:29:08 NVIDIA(0): The EDID for SHARP HDMI (DFP-0) contradicts itself: mode
    (WW) Mar 28 20:29:08 NVIDIA(0):     "1920x1080" is specified in the EDID; however, the EDID's
    (WW) Mar 28 20:29:08 NVIDIA(0):     valid VertRefresh range (49.000-76.000 Hz) would exclude
    (WW) Mar 28 20:29:08 NVIDIA(0):     this mode's VertRefresh (24.0 Hz); ignoring VertRefresh
    (WW) Mar 28 20:29:08 NVIDIA(0):     check for mode "1920x1080".
    (II) Mar 28 20:29:08 NVIDIA(0): Assigned Display Device: DFP-0
    (II) Mar 28 20:29:08 NVIDIA(0): Validated modes:
    (II) Mar 28 20:29:08 NVIDIA(0):     "DFP:nvidia-auto-select+0+0"
    (II) Mar 28 20:29:08 NVIDIA(0): Virtual screen size determined to be 1920 x 1080
    What's up with the "24.0 Hz"?


    Anyway I created a Modeline:
    Code:
    # gtf 1920 1080 60
    
      # 1920x1080 @ 60.00 Hz (GTF) hsync: 67.08 kHz; pclk: 172.80 MHz
      Modeline "1920x1080_60.00"  172.80  1920 2040 2248 2576  1080 1081 1084 1118  -HSync +Vsync
    added it to xorg.conf section monitor. But I couldn't log in afterwards. Screen started flickering and the mouse disappeared, after I had entered my login data.

    greetings

  4. #4
    Join Date
    Aug 2007
    Posts
    6,641

    Default

    First of all the modeline is wrong. It would be more like
    Code:
    $ cvt -r 1920 1080 60
    # 1920x1080 59.93 Hz (CVT 2.07M9-R) hsync: 66.59 kHz; pclk: 138.50 MHz
    Modeline "1920x1080R"  138.50  1920 1968 2000 2080  1080 1083 1088 1111 +hsync -vsync
    Also i dont think you posted all relevant lines from your logfile.

  5. #5
    Join Date
    Dec 2009
    Posts
    17

    Default

    Ok thanks, I used your modeline and at least I can log in again. However still at 50Hz.

    Don't know what exactly the relevant lines would be, so here is the whole Xorg.0.log:


    Hope you find missing information in there. Thanks!

  6. #6
    Join Date
    Aug 2007
    Posts
    6,641

    Default

    First of all there is no

    Option "TwinView" "0"

    if you want to see correct refresh rate in xrandr you have to use

    Option "DynamicTwinView" "0"

    otherwise you see 50 or 55 depending on the port used, only nvidia-settings will tell you the "real" refresh rate. I don't think that your tv is using 50 hz. You should not need any modeline override, try:

    rm /etc/X11/xorg.conf*
    nvidia-xconfig

    if you only use 1 connected monitor and want to see correct refresh:

    nvidia-xconfig --no-dynamic-twinview

  7. #7
    Join Date
    Dec 2009
    Posts
    17

    Default

    I created a new xorg.conf using the commands you provied.
    Still my monitor keep staying at 50Hz, also according to nvidia-settings.
    And personally I notice it by watching videos and starring at it a little longer (gives me kind of a headache and tiered eyes...)

    I saved edid data? Would this be helpful?

    Thank you for your efforts!

  8. #8
    Join Date
    Aug 2007
    Posts
    6,641

    Default

    You can use a tool to edit the edid.bin, then add this to the device section:

    Option "CustomEDID" "DFP-0:/path/to/some/edid.bin"

  9. #9
    Join Date
    Dec 2009
    Posts
    17

    Default

    I looked at the edid:
    Code:
    monitor-get-edid | monitor-parse-edid 
    Name: SHARP HDMI
    EISA ID: SHP0ffd
    Screen size: 82.0 cm x 46.0 cm (37.02 inches, aspect ratio 16/9 = 1.78)
    Gamma: 2.2
    Digital signal
    Max video bandwidth: 170 MHz
    
    	HorizSync 15-75
    	VertRefresh 49-76
    
    	# Monitor preferred modeline (50.0 Hz vsync, 56.2 kHz hsync, ratio 16/9, 59 dpi)
    	ModeLine "1920x1080" 148.5 1920 2448 2492 2640 1080 1084 1089 1125 -hsync +vsync
    
    	# Monitor preferred modeline (60.0 Hz vsync, 47.7 kHz hsync, ratio 16/9, 42 dpi)
    	ModeLine "1360x768" 85.5 1360 1424 1536 1792 768 771 777 795 +hsync +vsync
    I'm ready to change the edid.bin with a hex editor, but I'm not sure which value? Because 50(dec) (0x32) does not appear...

    greetings

  10. #10
    Join Date
    Dec 2009
    Posts
    17

    Default

    I tried using the windows edid file (shouldn't it be the same?) and got 60 Hz available for choosing in the display settings configuration tool, but it wasn't apllied...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •