Results 1 to 5 of 5

Thread: Is vanilla 2.6.31.2 compatible with Fedora 11's userspace?

  1. #1
    Join Date
    Jul 2007
    Posts
    446

    Default Is vanilla 2.6.31.2 compatible with Fedora 11's userspace?

    I've just compiled a 2.6.31.2 kernel, and tried to boot it against a Fedora 11 userspace environment, but X is refusing to initialise. The kernel mode-setting seems to start OK:

    Code:
    Linux agpgart interface v0.103
    agpgart-intel 0000:00:00.0: Intel E7505 Chipset
    agpgart-intel 0000:00:00.0: AGP aperture is 128M @ 0xc8000000
    [drm] Initialized drm 1.1.0 20060810
    [drm] radeon default to kernel modesetting.
    [drm] radeon kernel modesetting enabled.
    radeon 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
    [drm] radeon: Initializing kernel modesetting.
    [drm] register mmio base: 0xFF8F0000
    [drm] register mmio size: 65536
    [drm] GPU reset succeed (RBBM_STATUS=0x00000140)
    [drm] Clocks initialized !
    [drm] Generation 2 PCI interface, using max accessible memory
    [drm] Detected VRAM RAM=256M, BAR=256M
    [drm] RAM width 128bits DDR
    [drm] radeon: 1 quad pipes, 1 Z pipes initialized.
    agpgart-intel 0000:00:00.0: AGP 3.0 bridge
    agpgart-intel 0000:00:00.0: putting AGP V3 device into 8x mode
    radeon 0000:01:00.0: putting AGP V3 device into 8x mode
    [drm] radeon: VRAM 256M
    [drm] radeon: VRAM from 0x00000000 to 0x0FFFFFFF
    [drm] radeon: GTT 128M
    [drm] radeon: GTT from 0xC8000000 to 0xCFFFFFFF
    [drm] radeon: irq initialized.
    [TTM] TTM available graphics memory: 1008 MiB
    [TTM] TTM available object memory: 428 MiB
    [drm] radeon: 256M of VRAM memory ready
    [drm] radeon: 128M of GTT memory ready.
    [drm] radeon: cp idle (0x10000C03)
    [drm] Loading R300 Microcode
    [drm] radeon: ring at 0x00000000C8000000
    [drm] ring test succeeded in 1 usecs
    [drm] radeon: ib pool ready.
    [drm] ib test succeeded in 0 usecs
    [drm] Default TV standard: PAL
    [drm] 27.000000000 MHz TV ref clk
    [drm] DFP table revision: 4
    [drm] Radeon Display Connectors
    [drm] Connector 0:
    [drm]   VGA
    [drm]   DDC: 0x60 0x60 0x60 0x60 0x60 0x60 0x60 0x60
    [drm]   Encoders:
    [drm]     CRT1: INTERNAL_DAC1
    [drm] Connector 1:
    [drm]   DVI-I
    [drm]   DDC: 0x64 0x64 0x64 0x64 0x64 0x64 0x64 0x64
    [drm]   Encoders:
    [drm]     CRT2: INTERNAL_DAC2
    [drm]     DFP1: INTERNAL_TMDS1
    i2c-adapter i2c-0: unable to read EDID block.
    radeon 0000:01:00.0: VGA-1: no EDID data
    [drm] fb mappable at 0xE0040000
    [drm] vram apper at 0xE0000000
    [drm] size 7056000
    [drm] fb depth is 24
    [drm]    pitch is 6720
    [drm] TMDS-8: set mode 1680x1050 19
    Console: switching to colour frame buffer device 210x65
    fb0: radeondrmfb frame buffer device
    registered panic notifier
    [drm] radeon: kernel modesetting successfully initialized.
    [drm] Initialized radeon 2.0.0 20080528 for 0000:01:00.0 on minor 0
    But there's no Plymouth. The dmesg log ends like this:
    Code:
    [drm:radeon_cp_getparam_kms] *ERROR* invalid ioctl with kms radeon_cp_getparam_kms
    [drm:radeon_cp_getparam_kms] *ERROR* invalid ioctl with kms radeon_cp_getparam_kms
    [drm:radeon_cp_getparam_kms] *ERROR* invalid ioctl with kms radeon_cp_getparam_kms
    [drm:radeon_cp_getparam_kms] *ERROR* invalid ioctl with kms radeon_cp_getparam_kms
    [drm:radeon_cp_getparam_kms] *ERROR* invalid ioctl with kms radeon_cp_getparam_kms
    Is the X-server's radeon driver just too old, please?

    Thanks,
    Chris

  2. #2
    Join Date
    Dec 2007
    Posts
    2,371

    Default

    You need updated libdrm_radeon, xf86-video-ati, and mesa to use 2.6.31.x with F11.

  3. #3
    Join Date
    Jul 2007
    Posts
    446

    Default Rawhide?

    Quote Originally Posted by agd5f View Post
    You need updated libdrm_radeon, xf86-video-ati, and mesa to use 2.6.31.x with F11.
    Thanks; I take it that RawHide (F12) will be new enough? Or will RawHide need a 2.6.32 kernel? Come to think of it, assuming that 2.6.31.2 does work with RawHide, what are the prospects of 2.6.32 working with F12?

    Cheers,
    Chris
    Last edited by chrisr; 10-06-2009 at 03:57 AM.

  4. #4
    Join Date
    Dec 2007
    Posts
    2,371

    Default

    F12 should be fine.

  5. #5
    Join Date
    Jul 2007
    Posts
    446

    Default Roll on, Fedora 12

    Quote Originally Posted by agd5f View Post
    F12 should be fine.
    *Sigh*, I've got the Fedora 11 userspace running against 2.6.31.2 ATM by adding "modeset=0" to the initrd's init script. But F12's xorg-ati driver is refusing to compile against F11's xorg-x11-server-devel-1.6.4-0.1.fc11.i586 package. Something to do with the number of arguments in the xf86GetDefaultModes() prototype. So I'm guessing that the X server itself needs upgrading too.

    It will probably be simpler to upgrade to F12 itself - in one month's time?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •