Page 3 of 25 FirstFirst 1234513 ... LastLast
Results 21 to 30 of 243

Thread: AMD Catalyst 9.8 Delivers New Kernel Support

  1. #21
    Join Date
    Jul 2009
    Posts
    23

    Default

    Thanks for the release.

    In light of all the problems people are having, I'll wait till the rpmfusion guys have a go at packaging it.

  2. #22
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,795

    Default

    Still "not found" in the link to the release notes. IMO just shows how much attention they pay to the Linux release. It's not the first time they don't release properly.

  3. #23
    Join Date
    Apr 2009
    Location
    Toronto/North Bay Canada
    Posts
    877

    Default

    Quote Originally Posted by cruiseoveride View Post
    91.7mb? Don't you just love to hate AMD/ATi
    and? all of a sudden size matters?

  4. #24
    Join Date
    Jul 2008
    Posts
    1,726

    Default

    Quote Originally Posted by RealNC View Post
    Still "not found" in the link to the release notes. IMO just shows how much attention they pay to the Linux release. It's not the first time they don't release properly.
    release notes always lag a couple of hours behind because they are done by different people. Now would you calm down? The drivers don't stop working magically without that notes.

  5. #25
    Join Date
    Jun 2009
    Posts
    58

    Default preempt?

    Does it already work well with preemptive kernel? (not voluntary) Preemptive RCU? And big kernel lock?

  6. #26

    Default

    Quote Originally Posted by RealNC View Post
    Still "not found" in the link to the release notes. IMO just shows how much attention they pay to the Linux release. It's not the first time they don't release properly.
    wow, your not looking for a reason to hate amd.

    the windows link also became active before the release - who cares?

  7. #27
    Join Date
    Jun 2008
    Location
    New Zealand
    Posts
    68

    Default

    New kernel support is good. Other than that though, I haven't noticed anything else improved..

    RandR is still screwed for analogue monitors (since 9.6), spawning new X is crash provoking (since 9.7).

    I seriously hope that these issues get fixed sometime, especially the crashing one as it just makes the driver completely useless. If a can't spawn another X server then I can't use my computer for much productivity anymore.


    Well, at least the open drivers are progressing quickly anyway
    Last edited by poofyyoda; 08-18-2009 at 01:53 AM.

  8. #28
    Join Date
    Jun 2009
    Posts
    58

    Default

    Quote Originally Posted by poofyyoda View Post
    New kernel support is good. Other than that though, I haven't noticed anything else improved..

    RandR is still screwed for analogue monitors (since 9.6), spawning new X is crash provoking (since 9.7).

    I seriously hope that these issues get fixed sometime,
    It looks like they barely catch with the NEW stuff, and our hopes for getting the OLD stuff working are grim. I dont mean to whine, but seriously, look at the absurd state of it: I bought a pretty expensive piece of hardware and my bug is there, with no reply, rotting at the UNOFFICIAL bugzilla.

  9. #29
    Join Date
    Jun 2007
    Location
    .ro/.ca
    Posts
    232

    Default

    *sigh* Still doesn't work for me, and it's the same problem I've had for ages - black screen/freeze with no obvious error or warning messages (other than "unknown third party board (..)").
    I guess gaming on linux will have to wait some more.

  10. #30
    Join Date
    Dec 2007
    Location
    Germany
    Posts
    365

    Default

    Just installed 9.8, and I'm quite happy about the changes right now:
    - minimizing fullscreen OpenGL windows (or games which do support minimizing) works fine again; as long as I have turned off compositing at least
    - Nexuiz: bench1 FPS went from min/avg/max 18/33/74 to 16/37/93; Running Nexuiz in Wine runs at 13/33/84
    - Wine:
      - slow initialization bug from 9.7 seems to be fixed
      - I can select Shader quality PC3 Low and High in Trackmania Nations Forever now (these settings don't work correctly though because I'm getting quite a few graphical glitches then...); running at normal quality (PC2), I always get > 60 fps

    - Compiz alpha blur STILL does not work... C'mon focus blur works just fine, how hard can it be to fix alpha blurring?

    Things left to test:
    - xinit xterm -- :2 (oh well, would be cool if someone else could test it for me, don't have much time right now. Kept hardlocking my system since about 8.44)

    Quite a good release for me, now please AMD, fix Compiz' blur plugin and this driver is perfect for me
    Last edited by NeoBrain; 08-18-2009 at 07:25 AM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •