Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Ubuntu 9.04 & Catalyst 9.7 (fglrx)

  1. #1
    Join Date
    May 2009
    Location
    Canada
    Posts
    38

    Arrow Ubuntu 9.04 & Catalyst 9.7 (fglrx)

    Running Ubunty 9.04 Jaunty.

    I've been a long supporter of ATI, for over 10 years now in fact. Been hoping for a while now for the ATI+Linux scene to get better. I was happy for the past 6 months since the open source radeon driver became very stable with good 3D support for legacy cards. I had a Radeon X1950 Pro, dual monitors, and compiz effects enabled. I still couldn't play most games in linux, but rebooting into windows for this was temporarily acceptable for me.

    Well. After, unfortunately, waiting for 2 years now for the open source Radeon drivers to support OpenGL2, I decided to be a nice ATI customer and purchase a new card. I've purchased a shiny new ATI Radeon HD 4870 (RV770).

    Since the purpose of this purchase was to achieve "official linux support" from ATI again, I went straight to the Catalyst 9.7 drivers for fglrx. I followed the instructions at http://wiki.cchtml.com/index.php/Ubu...allation_Guide. The amdcccle didn't recognize that I had two monitors. It was either "clone", or some terrible form of Big Desktop (left monitor 1680x1050, right monitor 640x480). Any sort of tweaking to try for proper "Big Desktop" support often resulted in X crashing. Sad face; -- so much for an upgrade...

    For now, I'm using tormodvolden's edge radeonhd drivers (http://wiki.cchtml.com/index.php/Ubu...e_Edge_Drivers). At least they're stable, and support dual monitor "big desktop" mode. Unfortunately, I've lost support for 2D acceleration (compiz).

    Can anyone please suggest how I can get my brand new ATI card working with Linux using the proprietary drivers?

    In summary, I'm expecting the following to work:
    * fglrx proprietary driver -- stable
    * dual monitors (big desktop) mode (1680x1050 & 1680x1050)
    * 2D & 3D hardware acceleration
    * OpenGLx support for playing the latest native Linux 3D games, and at least the ability to "TRY" to play games in WINE (wine is beyond the scope of things here though, I realize this).

    My Hardware & Software versions:
    * 01:00.0 VGA compatible controller: ATI Technologies Inc RV770 [Radeon HD 4870]
    * Ubuntu 9.04 Jaunty (2.6.28-14-server)
    * xserver-xorg 1:7.4~5ubuntu18 the X.Org X server


    Thanks so much!

  2. #2
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,284

    Default

    Quote Originally Posted by fermulator View Post
    Since the purpose of this purchase was to achieve "official linux support" from ATI again, I went straight to the Catalyst 9.7 drivers for fglrx. I followed the instructions at http://wiki.cchtml.com/index.php/Ubu...allation_Guide. The amdcccle didn't recognize that I had two monitors. It was either "clone", or some terrible form of Big Desktop (left monitor 1680x1050, right monitor 640x480). Any sort of tweaking to try for proper "Big Desktop" support often resulted in X crashing. Sad face; -- so much for an upgrade...!
    I don't really understand the instructions at that link; I'll try to rationalize them with our install instructions over the weekend but for now you would probably have more success following the instructions that come with the driver package and only referencing other install instructions if you have questions or problems. I imagine all of the instructions on the net were correct at one point, but the installer package has changed significantly over the last couple of years.

    You should not need to edit the xorg.conf file. Most of the driver behaviour is controlled by a separate file - amdpcsdb. Both amdpcsdb and xorg.conf are set up by the aticonfig --initial command, with parameters for dual-head, multi-GPU etc...

    Did you run "sudo aticonfig --initial=dual-head" after installing the Catalyst driver ? I didn't see that mentioned in the link you posted. If you did not run with the dual-head option, give that a try as a first step. Your symptoms sound as if the driver was initialized as single head rather than dual head. If you have manually edited your xorg.conf file you might want to include the -f option, which allows aticonfig to significantly change portions of the xorg.conf file if necessary.

    Let us know whether you want to go with the open source or Catalyst drivers as a first step. If you want to get acceleration working on the open source drivers first, please pastebin your xorg log and dmesg output. If you want to go with the Catalyst drivers, we can go that way as well, but please try the instructions we provide with the driver package. You can either install "natively" or by building packages; recommend that you build packages for Ubunutu then install those packages.

    Regarding the open source drivers, Jaunty includes kernel and xf86-video-ati (radeon) support for EXA and Xv acceleration out of the box without needing to install radeonhd. If you don't have 2D acceleration with radeonhd, there are probably leftover bits of the Catalyst driver interfering with the open source kernel driver.
    Last edited by bridgman; 08-15-2009 at 03:02 AM.

  3. #3
    Join Date
    May 2009
    Location
    Canada
    Posts
    38

    Default

    Quote Originally Posted by bridgman View Post
    Did you run "sudo aticonfig --initial=dual-head" after installing the Catalyst driver ? I didn't see that mentioned in the link you posted. If you did not run with the dual-head option, give that a try as a first step. Your symptoms sound as if the driver was initialized as single head rather than dual head.
    Quote Originally Posted by bridgman View Post
    Let us know whether you want to go with the open source or Catalyst drivers as a first step. If you want to get acceleration working on the open source drivers first, please pastebin your xorg log and dmesg output. If you want to go with the Catalyst drivers, we can go that way as well, but please try the instructions we provide with the driver package. You can either install "natively" or by building packages; recommend that you build packages for Ubunutu then install those packages.
    What do you recommend Bridgman? Based on my "desired results" from the original post, can I achieve all of those things with either solution?

    As I mentioned, I was previously very happy with the open source drivers for the legacy cards (less the lack of OGL2 support), so this is why I purchased a new card. I would really like to have OpenGL support again for my graphics card. My guess is that this means I want to stick with the proprietary driver (for now) until the open source driver (and all that new crazy infrastructure) stabilizes, yes?

    RE the instructions on that wiki website, I've found that they always worked for me with the Ubuntu distro, but I haven't tried the ATI instructions for some time. Those instructions do have us generate deb packages from the ati installer. However, the "dual-head" parameter is not mentioned. I will try this! Thanks

  4. #4
    Join Date
    May 2009
    Location
    Canada
    Posts
    38

    Unhappy

    OK so I re-installed the proprietary drivers using --initial=dual-head.

    Here's more details on how I did this (used slightly modified instructions from that above website)

    1. Ensured I had all the necessary packages:
    Code:
    sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++5 dkms
    1. Downloaded download ati-driver-installer-9-7-x86.x86_64.run to /usr/local/src/ati/9.7.
    2. Built the distro specific packages (deb) for Ubuntu:
    Code:
    sh ati-driver-installer-9-7-x86.x86_64.run --buildpkg Ubuntu/jaunty
    3. Now I had all the debs ready for install. I don't care about the dev package though:
    Code:
    sudo mkdir dev
    sudo mv xorg-driver-fglrx-dev_*.deb dev
    4. Now install the remaining debs
    Code:
    sudo dpkg -i *.deb
    5. This was successful, yay!
    6. My previous xorg.conf was for the open source radeon drivers, so I modified it to the basic possible configuration:
    Section "Screen"
    Identifier "Configured Screen Device"
    Device "Configured Video Device"
    EndSection

    Section "Device"
    Identifier "Configured Video Device"
    Driver "fglrx"
    EndSection

    Section "ServerFlags"
    Option "DontZap" "False"
    EndSection
    7. Then I ran:
    Code:
    sudo aticonfig --initial=dual-head -f
    8. Reboot.

    The system rebooted without crash. When I logged in however, the "dual head" configuration wasn't really right. It seemed like it had two separate X sessions, one for monitor. compiz desktop effects however DID work. When I moved the mouse across, it would behave strangely and jump around. This isn't what I wanted, I want "big desktop" mode, where you can drag windows between the two monitors.

    1. Fire up AMD Catalyst Control Center:
    Code:
    gksu amdcccle


    Again, I'll reiterate. Under the "Display Manager", in the "Multi-Display" tab, "Display Configuration". I'm expecting to see an option in the drop down box called "Big Desktop", but it's not there. The only options for "Multi-Display" are "Single (Independent Display)" and "Unknown". :-(

    2. Under "Display Options" I tried Xinerama, but it's really buggered. After a reboot, i can *almost* drag windows across, but they don't quite use the enter "secondary" screen... it's buggered. Since enabling xinerama, compiz no longer works.

    This is the xorg.conf that aticonfig generated for me: http://pastebin.com/f7f6f5981
    Last edited by fermulator; 08-15-2009 at 09:39 AM. Reason: minor changes

  5. #5
    Join Date
    May 2009
    Location
    Canada
    Posts
    38

    Default

    "bump"? :-0

  6. #6
    Join Date
    May 2007
    Posts
    352

    Default

    Run this command to change your xorg configuration so that xrandr is disabled:

    aticonfig --set-pcs-str="DDX,EnableRandR12,FALSE"

    Then restart X and you should see "Big Desktop" as an option.

    AMD should make that the default till they fix their buggy xrandr implementation.

    Adam

  7. #7
    Join Date
    May 2009
    Location
    Canada
    Posts
    38

    Thumbs up

    Quote Originally Posted by adamk View Post
    Run this command to change your xorg configuration so that xrandr is disabled:

    aticonfig --set-pcs-str="DDX,EnableRandR12,FALSE"

    Then restart X and you should see "Big Desktop" as an option.

    AMD should make that the default till they fix their buggy xrandr implementation.

    Adam
    Thanks Adam, this allowed me to choose Big Desktop!

  8. #8
    Join Date
    Jul 2008
    Location
    Half Moon Bay, CA
    Posts
    6

    Default Only one screen shows

    I *really* tried before posting here. My goal is to have a dual monitor system, with one screen in landscape orientation and one screen in portrait orientation. This is what I have tried so far. Would someone please answer the questions I raised in that post, and give me some direction? Apologies for the length of the posting I reference, but I felt it important to show the history in case my actions caused mischievous cruft to be scattered about.

    Thanks,

    Mike

  9. #9
    Join Date
    Jul 2008
    Location
    Half Moon Bay, CA
    Posts
    6

    Default Looking forward to a response :)

    Can anyone help?

    Thanks,

    Mike

  10. #10
    Join Date
    May 2009
    Location
    Canada
    Posts
    38

    Default

    Quote Originally Posted by mslinn View Post
    Can anyone help?

    Thanks,

    Mike
    Try the latest catalyst drivers, they work better with defaults.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •