Results 1 to 7 of 7

Thread: Intel Releases xf86-video-intel 2.8 RC Driver

  1. #1
    Join Date
    Jan 2007
    Posts
    13,433

    Default Intel Releases xf86-video-intel 2.8 RC Driver

    Phoronix: Intel Releases xf86-video-intel 2.8 RC Driver

    In preparation for Intel's quarterly DDX driver update, Carl Worth has announced the first release candidate of the xf86-video-intel 2.8 driver. This driver is significant in that it completely abolishes DRI1 and EXA support in favor of only supporting DRI2 and UXA, respectively.The UMA Acceleration Architecture is derived from EXA and was supposed to be merged back into EXA, but that didn't end up happening...

    http://www.phoronix.com/vr.php?view=NzM3OQ

  2. #2
    Join Date
    Nov 2007
    Posts
    116

    Default

    I hope they manage to fix the XVideo tearing which I am seeing on a 945 with xorg-x11-drv-intel-2.7.0-7.fc11. Option "XvPreferOverlay" doesn't seem to work, either.

  3. #3
    Join Date
    Aug 2008
    Posts
    233

    Default

    Quote Originally Posted by CrystalCowboy View Post
    I hope they manage to fix the XVideo tearing which I am seeing on a 945 with xorg-x11-drv-intel-2.7.0-7.fc11. Option "XvPreferOverlay" doesn't seem to work, either.
    From 2.7 to 2.8rc there is a big difference, almost everything works now.

  4. #4
    Join Date
    Nov 2007
    Posts
    116

    Default

    Sounds good. I hope it makes it through the Fedora distribution pipeline soon.

  5. #5
    Join Date
    Mar 2009
    Posts
    5

    Default

    Note that Intel has also tagged 2009Q2RC1 in the mesa 7.5 branch. Seems this driver will use mesa 7.5 when it's released as stable.

  6. #6
    Join Date
    Dec 2008
    Posts
    62

    Default

    Quote Originally Posted by KDesk View Post
    From 2.7 to 2.8rc there is a big difference, almost everything works now.
    So what's not working?

  7. #7
    Join Date
    Aug 2008
    Posts
    233

    Default

    Quote Originally Posted by kxmas View Post
    So what's not working?
    It's almost working, but I have random freezes in 865G http://bugs.freedesktop.org/show_bug.cgi?id=22483

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •