Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Does Sacred Gold freeze the OS for you ?

  1. #1
    Join Date
    Jun 2008
    Posts
    29

    Default Does Sacred Gold freeze the OS for you ?

    Hi,

    I'd like to know if other people have the same issue with Sacred Gold than I have. Upon starting an adventure (for instance the gladiator), I have very soon a complete hard freeze. Sounds loops for a couple of seconds and then the system is totally frozen (cannot change console, no response from keybord, etc.) There is no error message in console and the debug file does not reveal anything. In the case of the gladiator, this occurs as soon as the character enters the arena at the beginning. I see the same problem with other characters, and in the Underworld campaign.

    This occurs in my 2 Linux distros (Mandriva 2009.1 and Arch Linux) with 2 different versions of the nvidia proprietary driver. My graphics card is a 7600GT AGP. It also happens if sound is disabled.

    I have contacted LGP about it, but they told me it would take time because I seem to be the only one to have this problem.

    I am trying to find other people who have the same issue, in order to help the debugging.

    Thanks a lot in advance.

  2. #2
    Join Date
    Jun 2006
    Location
    Poland
    Posts
    117

    Default

    Quote Originally Posted by zeb_ View Post
    Hi,

    I'd like to know if other people have the same issue with Sacred Gold than I have. Upon starting an adventure (for instance the gladiator), I have very soon a complete hard freeze.
    Can you try running game like this:
    strace -f -o sacred.log sacred
    Lower your graphic settings(you might want to post them here) and try again.
    After that can you try some graphic intensive program to check if bug also occurs?

    Quote Originally Posted by zeb_ View Post
    Sounds loops for a couple of seconds and then the system is totally frozen (cannot change console, no response from keybord, etc.)
    You might don't like it but your problem is similar(if not identical) to what was occurring to me when I had broken mainboard(due to faulty PSU).

    Quote Originally Posted by zeb_ View Post
    There is no error message in console and the debug file does not reveal anything. In the case of the gladiator, this occurs as soon as the character enters the arena at the beginning. I see the same problem with other characters, and in the Underworld campaign.

    This occurs in my 2 Linux distros (Mandriva 2009.1 and Arch Linux) with 2 different versions of the nvidia proprietary driver. My graphics card is a 7600GT AGP. It also happens if sound is disabled.
    Try to lower agp mode and disable fast writes(I don't remember name of other option), if it doesn't help switch your card into pci mode.
    http://http.download.nvidia.com/XFre...ppendix-f.html

    Quote Originally Posted by zeb_ View Post
    I have contacted LGP about it, but they told me it would take time because I seem to be the only one to have this problem.

    I am trying to find other people who have the same issue, in order to help the debugging.

    Thanks a lot in advance.
    I smell hardware problems rather than software ones. Especially AGP part. You should make sure that AGP card have enough power. In this case I would start from power supply. Checking capacitors on your mainboard also might help.
    Generally check your hardware.

    ps. I don't have this problem with sacred.

  3. #3
    Join Date
    Jun 2008
    Posts
    29

    Default

    Mmmmh... I doubt this is a hardware problem. I have been playing Enemy Territory, Doom 3, Prey, Quake 4, Neverwinter Nights, Jet's and Guns, Majesty, and Penumbra on that same machine without any issue of that kind. Sacred is less demanding than Doom 3 or Enemy Territory for instance.

    I'll try your recommendations though (strace and other nvidia options). Thanks for your help.

  4. #4
    Join Date
    Jun 2006
    Location
    Poland
    Posts
    117

    Default

    Quote Originally Posted by zeb_ View Post
    Mmmmh... I doubt this is a hardware problem. I have been playing Enemy Territory, Doom 3, Prey, Quake 4, Neverwinter Nights, Jet's and Guns, Majesty, and Penumbra on that same machine without any issue of that kind. Sacred is less demanding than Doom 3 or Enemy Territory for instance.
    You might be surprised how erratic broken hardware can acts. Sacred might just use features (CPU, GPU or timing) that trigger the crash.
    Don't forget to do the memtest and stress test cpu.

    Quote Originally Posted by zeb_ View Post
    I'll try your recommendations though (strace and other nvidia options). Thanks for your help.
    You might want to use more recent readme, one that I linked to is fairly old.

  5. #5
    Join Date
    Jun 2008
    Posts
    29

    Default

    Which CPU stress software do you use ?

  6. #6
    Join Date
    Jun 2008
    Posts
    29

    Default

    Well, AGP Fast Write option does not exist anymore, but I can try to diasble AGP entirely with NvAGP 0 option.
    Last edited by zeb_; 05-20-2009 at 05:38 PM.

  7. #7
    Join Date
    Jun 2008
    Posts
    29

    Default

    OK, that was it! Option "NvAGP" "0" leads to the game not crashing! That's great news, because I will be able to report this to LGP for, hopefully, a patch. Because the 3D is however quite slow (but playable).

  8. #8
    Join Date
    Jun 2008
    Posts
    29

    Default

    I am very VERY puzzled now. I have put back my xorg.conf file as before (automatic AGP), to reproduce the bug (and reboot). And guess what, it does not crash anymore. Even after a cold reboot (shutdown, then unplugging then boot).
    I even restarted in ArchLinux and it DOES work!!!

    I don't know what to think of it. Have some registers on my graphics card been changed ? (I had a sound card which could not restart when soft boot). I really don't understand what is going on.

    EDIT: I had a crash under Arch. But this did not occur as soon as I entered the arena, a little later. However, I am unable to get the crash in Mandriva anynmore, with the previous xorg.conf file, even after reboot! I will see tomorrow if I can do it again. But I really do not understand the problem...
    Last edited by zeb_; 05-20-2009 at 06:02 PM.

  9. #9
    Join Date
    Jun 2006
    Location
    Poland
    Posts
    117

    Default

    Quote Originally Posted by zeb_ View Post
    I am very VERY puzzled now. I have put back my xorg.conf file as before (automatic AGP), to reproduce the bug (and reboot). And guess what, it does not crash anymore. Even after a cold reboot (shutdown, then unplugging then boot).
    I even restarted in ArchLinux and it DOES work!!!

    I don't know what to think of it. Have some registers on my graphics card been changed ? (I had a sound card which could not restart when soft boot). I really don't understand what is going on.

    EDIT: I had a crash under Arch. But this did not occur as soon as I entered the arena, a little later. However, I am unable to get the crash in Mandriva anynmore, with the previous xorg.conf file, even after reboot! I will see tomorrow if I can do it again. But I really do not understand the problem...
    I'm sorry but after you posted that "NvAGP 0" solves your problem I have very strong basis to assume that it's indeed hardware problem.
    And it might not be faulty hardware, agp just doesn't old well. Older computer get noisier and agp might react in many unpleasant ways.

    Can you try lowering agp mode in bios? Turning off some "fast" option there? Or even enable some noise correction option?

    Your computer might be too noisy for agpx4.

  10. #10
    Join Date
    Jun 2006
    Location
    Poland
    Posts
    117

    Default

    Quote Originally Posted by zeb_ View Post
    Which CPU stress software do you use ?
    Stress.
    You can use package from your distribution or get it directly from this website:
    http://weather.ou.edu/~apw/projects/stress/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •