Page 7 of 8 FirstFirst ... 5678 LastLast
Results 61 to 70 of 74

Thread: Caster has gone Gold!

  1. #61
    Join Date
    Aug 2007
    Posts
    6,631

    Default

    After looking at your problem description that reminded me of an error that lead to 100% cpu usage with a dbase app compiled with xHarbour. Basically they used busy waiting without any sleeps, that caused the extreme cpu usage. It was not that extreme with older kernels but new ones showed it. I usually do not fix compiler bugs, but it was relatively easy to locate this one. I do not write dbase apps, just somebody showed me that problem and i found a hack around it.

  2. #62
    Join Date
    Aug 2007
    Posts
    6,631

    Default

    @Svartalf

    So found the demo 1.1 update. Seems to run really smooth now. Can you tell us how to enable a framecounter?

    Btw. it does not seem that there is a ingame editor in the demo, did you enable it for the full version?

    https://docs.google.com/Doc?docid=dd...gxfnrxgb&hl=en

  3. #63
    Join Date
    Jun 2006
    Posts
    3,046

    Default

    Quote Originally Posted by Kano View Post
    @Svartalf

    So found the demo 1.1 update. Seems to run really smooth now. Can you tell us how to enable a framecounter?
    Currently only in the developer version of the binary. I'll forward a request to Mike on that one.

    Btw. it does not seem that there is a ingame editor in the demo, did you enable it for the full version?

    https://docs.google.com/Doc?docid=dd...gxfnrxgb&hl=en
    The Google doc mentions the in-game, but unfortunately Mike's only enabled it in the developer edition. That may change over time, but for now...

  4. #64
    Join Date
    Aug 2007
    Posts
    6,631

    Default

    Is the Windows binary the developer version? Would be stupid when somebody already bought the Linux one...

  5. #65
    Join Date
    Jun 2006
    Posts
    3,046

    Default

    Quote Originally Posted by Kano View Post
    Is the Windows binary the developer version? Would be stupid when somebody already bought the Linux one...
    No... It's one built for debug right at the moment...

  6. #66
    Join Date
    Aug 2007
    Posts
    6,631

    Default

    From the Win demo:

    strings caster.exe |grep FPS
    >"Caster". FPS: %.2f FPS (perf): %.2f Swap Time: %.2f

    So it is build for debug then? How to enable it there?

  7. #67
    Join Date
    Jun 2006
    Posts
    3,046

    Default

    Quote Originally Posted by Kano View Post
    >"Caster". FPS: %.2f FPS (perf): %.2f Swap Time: %.2f

    So it is build for debug then? How to enable it there?
    I was referring to the editor. I'm not wholly sure how to turn on perf counting from the Windows or Linux side (Didn't need to- used BuGLe to get framecounts, etc. as I was verifying GL code, etc...); I'll check into it when I get home and get back with you on that one.

  8. #68
    Join Date
    Dec 2006
    Posts
    222

    Default

    I just picked this up. Do i still need to update the game using the demo, or is the full game binary up to date by now?

  9. #69
    Join Date
    Jun 2006
    Posts
    3,046

    Default

    Quote Originally Posted by Raven3x7 View Post
    I just picked this up. Do i still need to update the game using the demo, or is the full game binary up to date by now?
    If you just bought, it should be the version with the performance problem fixes in it. If you encounter slowdowns, you might need to download the update. If so, I can point you in the right direction shortly. Just let me know.

  10. #70
    Join Date
    Aug 2007
    Posts
    6,631

    Default

    Any update for the FPS code?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •