Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: 2.6.29-ARCH (X86_X64)+catalyst 9.4-1+compiz fusion = massive failure

  1. #1
    Join Date
    May 2009
    Posts
    10

    Thumbs down 2.6.29-ARCH (X86_X64)+catalyst 9.4-1+compiz fusion = massive failure

    I posted my thread on archlinux forums (my distro) but alas no response, so i'm hoping if anyone else could help me? I'm currently running 2.6.29 kernel with catalyst 9.4, sure enough it "works" as in I have X+DE (kde4= up and running but compiz runs like shit. Basically I wan't most of the plugins/3D in compiz to work, like wobbly windows, but everytime i try one, all the windows/borders goes static.

    Should I downgrade my catalyst or try xf86-video-radeonhd (im currently at work) ?

    Trust me if I could rip out my "lovely" ATI from my sony vaio, I would trust me and go with nvidia instead.


    Here's my problem after a few hours of fiddling I at least managed to get compiz up and running with a few plugins, but wobbly windows/alt tab/moving windows (very important to me) does not work at all. Everytime I execute any command on the wiki that's related to emerald/fusion icon/kde etc all my windows goes into some sort of static mode, can't move them around, can't do anything at all unless I execute: kwin --replace.

    my dmesg log is full of this crap:

    Code:
     data!!! vma_start:0x7fef335b6000,handle:0xc5e76000
    [fglrx:firegl_find_any_map] *ERROR* Invalid map handle!<3>[fglrx:drm_vm_open] *ERROR* map not found -> inconsistent kernel data!!! vma_start:0x7fef339ea000,handle:0xc29ec000
    (won't paste the entire content in here) check out my paste if you wish: EDIT: I can't paste all those lines WOW! "time out while sending data" just imagine i have 800 lines of the same crap

    compiz fusion errors running fusion-icon (notice the errors I get from running wobbly windows)

    Code:
     * Detected Session: kde
     * Searching for installed applications...
     * No GLX_EXT_texture_from_pixmap with direct rendering context
     ... present with indirect rendering, exporting: LIBGL_ALWAYS_INDIRECT=1
     * Using the GTK Interface
     * Starting Compiz
     ... executing: compiz --replace --sm-disable --ignore-desktop-hints ccp --indirect-rendering
    compiz (core) - Error: Plugin 'text' not loaded.
    
    compiz (ring) - Warn: No compatible text plugin found.
    compiz (cube) - Warn: Failed to load slide: freedesktop
    compiz (core) - Error: Plugin 'text' not loaded.
    
    compiz (group) - Warn: No compatible text plugin loaded.
    Code:
    Linux archbox 2.6.29-ARCH #1 SMP PREEMPT Wed Apr 29 15:36:46 CEST 2009 x86_64 Intel(R) Core(TM)2 Duo CPU P8400 @ 2.26GHz GenuineIntel GNU/Linux
    Code:
    HARDWARE DETECT ver 5.5 (simple mode)
      Kernel     : 2.6.29-ARCH
      CPU & Cache: Processor 0: Intel(R) Core(TM)2 Duo CPU     P8400  @ 2.26GHz 2267MHz, 3072 KB Cache
    Processor 1: Intel(R) Core(TM)2 Duo CPU     P8400  @ 2.26GHz 2267MHz, 3072 KB Cache
    
      Sound(a)   : 82801I ICH9 Family HD Audio Controller module: snd-hda-intel
      Sound(a)   : RV620 Audio device [Radeon HD 34xx Series] module: snd-hda-intel
      Video      : Mobility Radeon HD 3400 Series server: Xorg (vesa)
      Driver     : xf86-video-vesa   module: -
      Monitor    : Generic Monitor  H: 28.0-96.0kHz V: 50.0-75.0Hz
      Mouse      : Logitech, Inc. V220 Cordless Optical Mouse xtype: IMPS2 device: /dev/input/mice
      USB        : 82801I ICH9 Family USB UHCI Controller #3 module: uhci_hcd
      USB2       : 82801I ICH9 Family USB2 EHCI Controller #1 module: ehci_hcd
      SD Slot    : R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter module: sdhci-pci
    
      Ethernet   : 88E8055 PCIE Gigabit Ethernet Controller module: sky2
      Network    : Wireless WiFi Link 5100 module: iwlagn
      Firewire   : R5C832 IEEE 1394 Controller  module: ohci1394
    Code:
     pacman -Q catalyst/catalyst-utils 9.4-1
    Code:
    KDE compiz-fusion group
    ccsm, compiz-fusion-plugins-extra, compiz-fusion-plugins-main, compizconfig-backend-kconfig, emerald, emerald-themes, fusion-icon
    Code:
    # **********************************************************************
    # Module section -- this  section  is used to specify
    # which dynamically loadable modules to load.
    # **********************************************************************
    #
    # **********************************************************************
    # Files section.  This allows default font and rgb paths to be set
    # **********************************************************************
    # **********************************************************************
    # Server flags section.
    # **********************************************************************
    # **********************************************************************
    # Monitor section
    # **********************************************************************
    # Any number of monitor sections may be present
    # **********************************************************************
    # Graphics device section
    # **********************************************************************
    # Any number of graphics device sections may be present
    # **********************************************************************
    # Screen sections
    # **********************************************************************
    # Any number of screen sections may be present.  Each describes
    # the configuration of a single screen.  A single specific screen section
    # may be specified from the X server command line with the "-screen"
    # option.
    # **********************************************************************
    # ServerLayout sections.
    # **********************************************************************
    # Any number of ServerLayout sections may be present.  Each describes
    # the way multiple screens are organised.  A specific ServerLayout
    # section may be specified from the X server command line with the
    # "-layout" option.  In the absence of this, the first section is used.
    # When now ServerLayout section is present, the first Screen section
    # is used alone.
    
    Section "ServerLayout"
    	Identifier     "Xorg Configured"
    	Screen      0  "aticonfig-Screen[0]-0" 0 0
    EndSection
    
    Section "Files"
    
    # Additional fonts: Locale, Gimp, TTF...
    #	FontPath     "/usr/share/lib/X11/fonts/latin2/75dpi"
    #	FontPath     "/usr/share/lib/X11/fonts/latin2/100dpi"
    # True type and type1 fonts are also handled via xftlib, see /etc/X11/XftConfig!
    	ModulePath   "/usr/lib/xorg/modules"
    	FontPath     "/usr/share/fonts/misc:unscaled"
    	FontPath     "/usr/share/fonts/misc"
    	FontPath     "/usr/share/fonts/75dpi:unscaled"
    	FontPath     "/usr/share/fonts/75dpi"
    	FontPath     "/usr/share/fonts/100dpi:unscaled"
    	FontPath     "/usr/share/fonts/100dpi"
    	#FontPath     "/usr/share/fonts/PEX"
    	#FontPath     "/usr/share/fonts/cyrillic"
    	#FontPath     "/usr/share/fonts/Type1"
    	#FontPath     "/usr/share/fonts/ttf/western"
    	#FontPath     "/usr/share/fonts/ttf/decoratives"
    	#FontPath     "/usr/share/fonts/truetype"
    	#FontPath     "/usr/share/fonts/truetype/openoffice"
    	#FontPath     "/usr/share/fonts/truetype/ttf-bitstream-vera"
    	#FontPath     "/usr/share/fonts/latex-ttf-fonts"
    	#FontPath     "/usr/share/fonts/defoma/CID"
    	#FontPath     "/usr/share/fonts/defoma/TrueType"
    EndSection
    
    Section "Module"
    	Load  "ddc"  # ddc probing of monitor
    	Load  "dbe"
    	Load  "dri"
    	Load  "extmod"
    	Load  "glx"
    	Load  "bitmap" # bitmap-fonts
    	#Load  "type1"
    	Load  "freetype"
    	#Load  "record"
    	Load  "evdev"
    EndSection
    
    Section "ServerFlags"
    	Option	    "AllowMouseOpenFail" "true"
    	Option	    "AutoAddDevices" "true"
            Option      "DontZap" "false"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Touchpad"
    	Driver      "synaptics"
    	Option	    "Device" "/dev/input/mouse0"
    	Option	    "Protocol" "auto-dev"
    	Option	    "LeftEdge" "130"
    	Option	    "RightEdge" "840"
    	Option	    "TopEdge" "130"
    	Option	    "BottomEdge" "640"
    	Option	    "FingerLow" "7"
    	Option	    "FingerHigh" "8"
    	Option	    "MaxTapTime" "180"
    	Option	    "MaxTapMove" "110"
    	Option	    "EmulateMidButtonTime" "75"
    	Option	    "VertScrollDelta" "20"
    	Option	    "HorizScrollDelta" "20"
    	Option	    "MinSpeed" "0.25"
    	Option	    "MaxSpeed" "0.50"
    	Option	    "AccelFactor" "0.010"
    	Option	    "EdgeMotionMinSpeed" "200"
    	Option	    "EdgeMotionMaxSpeed" "200"
    	Option	    "UpDownScrolling" "1"
    	Option	    "CircularScrolling" "1"
    	Option	    "CircScrollDelta" "0.1"
    	Option	    "CircScrollTrigger" "2"
    	Option	    "SHMConfig" "on"
    	Option	    "Emulate3Buttons" "on"
    EndSection
    
    Section "Monitor"
     # Warning: This may fry old Monitors
     # Very conservative. May flicker.
    #	VertRefresh  50.0 - 62.0 # Extreme conservative. Will flicker. TFT default.
    	Identifier   "Monitor0"
    	HorizSync    28.0 - 96.0
    	VertRefresh  50.0 - 75.0
    	Option	    "DPMS" "true"
    #	HorizSync    28.0 - 78.0 # Warning: This may fry very old Monitors
    EndSection
    
    Section "Monitor"
    	Identifier   "aticonfig-Monitor[0]-0"
    	Option	    "VendorName" "ATI Proprietary Driver"
    	Option	    "ModelName" "Generic Autodetecting Monitor"
    	Option	    "DPMS" "true"
    EndSection
    
    Section "Device"
    	Identifier  "Card0"
    	Driver      "radeonhd"
    	VendorName  "ATI Technologies Inc"
    	BoardName   "Mobility Radeon HD 3400 Series"
    	BusID       "PCI:1:0:0"
    EndSection
    
    Section "Device"
    	Identifier  "aticonfig-Device[0]-0"
    	Driver      "fglrx"
    	BusID       "PCI:1:0:0"
    EndSection
    
    
    Section "Screen"
    	Identifier "aticonfig-Screen[0]-0"
    	Device     "aticonfig-Device[0]-0"
    	Monitor    "aticonfig-Monitor[0]-0"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection
    
    Section "DRI"
    	Group        "video"
    	Mode         0666
    EndSection
    
    Section "Extensions"
          Option "Composite" "Enabled"
    EndSection
    Anyone running ati open source drivers with compiz/3d effects without issues?

  2. #2
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,571

    Default

    I didn't think we were supporting the 2.6.29 kernel yet, but maybe I missed a release note somewhere. AFAIK we have early look support for server 1.6 but not kernel 2.6.29. Downgrading the kernel would probably be more help than downgrading the driver.

    The open source drivers work well with compiz and effects on pre-6xx cards, but support for the new 3d engine in 6xx and 7xx (ie your card) is just going in now.
    Last edited by bridgman; 05-06-2009 at 10:36 AM.

  3. #3

    Default

    Hey bridgeman,
    I was in a (sorta) similiar position to you. I found that upgrading my arch to xorg1.6 resulted in the black screen of death using fglrx.

    What I did was take my xorg1.4 packages, installed those, pinned them using IgnorePkg's, then I did a pacman -Syu and installed fglrx from the ati package (yeah, not using abs, so sue me

    Result ? upto date arch system -apart- from the xorg1.4 and current fglrx. So. my advice would be to roll back the xorg to the 'good' release of 1.4 and ignore the 1.5/1.6 releases. If you pin the xf86-video and xf86-input's as well, then you can still do system wide updates without too much trouble

    Regards
    Stef

  4. #4
    Join Date
    May 2009
    Posts
    10

    Default

    Quote Originally Posted by bridgman View Post
    I didn't think we were supporting the 2.6.29 kernel yet, but maybe I missed a release note somewhere. AFAIK we have early look support for server 1.6 but not kernel 2.6.29. Downgrading the kernel would probably be more help than downgrading the driver.

    The open source drivers work well with compiz and effects on pre-6xx cards, but support for the new 3d engine in 6xx and 7xx (ie your card) is just going in now.
    Thanks for takin time to respond to my post bridgman, aka an ATI dev . (didn't know you guys were on the board)

    You're right you don't support the 2.6.29 kernel yet, canoical isn't there yet.

    You were also correct about the OS drivers, but I still tried them and yeah white screen/freeze trying to launch compiz so no luck there.

    I will take your advice and try downgrading my current kernel, thank you.

  5. #5
    Join Date
    May 2009
    Posts
    10

    Default

    Quote Originally Posted by Stef Telford View Post
    Hey bridgeman,
    I was in a (sorta) similiar position to you. I found that upgrading my arch to xorg1.6 resulted in the black screen of death using fglrx.

    What I did was take my xorg1.4 packages, installed those, pinned them using IgnorePkg's, then I did a pacman -Syu and installed fglrx from the ati package (yeah, not using abs, so sue me

    Result ? upto date arch system -apart- from the xorg1.4 and current fglrx. So. my advice would be to roll back the xorg to the 'good' release of 1.4 and ignore the 1.5/1.6 releases. If you pin the xf86-video and xf86-input's as well, then you can still do system wide updates without too much trouble

    Regards
    Stef
    Thank you, I will try your solution as well.

  6. #6
    Join Date
    May 2009
    Posts
    10

    Default

    ugh I need some help here, downgrading my kernel/xorg just leaves me with a broken archbox (lots of broken dependencies).

    Also my worst problem right now is that my fans are constantly spinning at full speed (cant regulate - sony vaio here), yes i'm talking about the GPU fan. Also running any video in full screen with vlc/mplayer crashes my entire computer, have to shutdown usin the power button

    Any ideas?

    Linux archbox 2.6.29-ARCH #1 SMP PREEMPT Wed Apr 29 15:36:46 CEST 2009 x86_64 Intel(R) Core(TM)2 Duo CPU P8400 @ 2.26GHz GenuineIntel GNU/Linux
    Last edited by greenfish; 05-11-2009 at 02:24 PM.

  7. #7
    Join Date
    Oct 2007
    Location
    Under the bridge
    Posts
    2,153

    Default

    I wouldn't suggest downgrading xorg...

    Right now, I am running Arch x86_64 with the 2.6.29 kernel, xserver 1.6 and catalyst 9.4 (4850) with no problems. IIRC, catalyst 9.5 will be released tomorrow - maybe it works better.

  8. #8
    Join Date
    Aug 2007
    Posts
    6,674

    Default

    @greenfish

    http://packages.ubuntu.com/search?ke...ic&section=all

    They skipped 2.6.29, but there is 2.6.30 rc already available on U karmic.

  9. #9
    Join Date
    Nov 2008
    Location
    Germany
    Posts
    5,411

    Default

    Quote Originally Posted by bridgman View Post
    I didn't think we were supporting the 2.6.29 kernel yet,
    Yes, Yes, Yes PLEEEEEASE

    i know i know!

  10. #10
    Join Date
    May 2009
    Posts
    10

    Default

    Quote Originally Posted by Kano View Post
    @greenfish

    http://packages.ubuntu.com/search?ke...ic&section=all

    They skipped 2.6.29, but there is 2.6.30 rc already available on U karmic.
    Cool but no debian/sysv here, arch

    Using the most recent catalyst 9.5 still gives me the same results

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •