Page 1 of 10 123 ... LastLast
Results 1 to 10 of 98

Thread: AMD Catalyst 9.4 Finally Brings X Server 1.6 Support

  1. #1
    Join Date
    Jan 2007
    Posts
    15,090

    Default AMD Catalyst 9.4 Finally Brings X Server 1.6 Support

    Phoronix: AMD Catalyst 9.4 Finally Brings X Server 1.6 Support

    X Server 1.6 was released back in February, and there have been test releases for it going back to the end of last year, but today AMD has finally delivered support for this new X.Org server in their proprietary Linux graphics driver. Like last month with the Catalyst 9.3 release, the Linux version was not released on the same day as the Windows build, which ended up being a one-week delay. Besides X Server 1.6 support there are also a few other changes in Catalyst 9.4 worth reporting.

    http://www.phoronix.com/vr.php?view=13720

  2. #2
    Join Date
    Dec 2008
    Posts
    57

    Default

    Compiz + XV --> 100% CPU-Usage --> trying to stop --> Xserver-freeze
    Compiz + gl-output --> heavy tearing even with enabled vsync

    Well i'm glad, that i can switch to jaunty next week.

  3. #3
    Join Date
    Dec 2008
    Location
    Poland
    Posts
    119

    Default

    Well in 9.4 they've dropped support for r300-r500 and haven't added any spectacular feature like every month (beside xserver 1.6 support) and the size of the binary file is even bigger than before. How is this possible? Does dropping support for r300-r500 meant only setting flag from 1 to 0 for these chips?

  4. #4
    Join Date
    Jul 2008
    Posts
    77

    Default

    NSLW:

    Have the drivers literally stopped working with R300-R500, or are they just not developing any further for these chips? Either way, it sounds like they left the code in for said cards -- that, or what they needed to add for xserver 1.6 support somehow required more resources.
    Last edited by aaaantoine; 04-17-2009 at 12:47 PM.

  5. #5
    Join Date
    Jan 2009
    Posts
    148

    Default

    Quote Originally Posted by NSLW View Post
    and the size of the binary file is even bigger than before. How is this possible?
    Maybe they are working on new features, who knows?

  6. #6
    Join Date
    Jun 2008
    Posts
    33

    Default

    Can this legacy code (r1xx-r5xx) be activated in this driver? could any amd engineer shed some light on this? i prefer to mess with an unstable/unsuported driver just for fun, that no driver at all although i'm quitte happy with the open source radeon one

  7. #7

    Default

    to add to the questions being tossed around:

    Crossfire support for R600-R700 cards? I'm still waiting for My Crossfired HD 3870's to be useful under Linux.

  8. #8
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,514

    Default

    I think the 3xx-5xx code will get removed as time permits, so most of it is probably still in the driver today -- but since pre-6xx support is not being regression-tested and fixed as we make changes for 6xx and newer parts you should probably assume that pre-6xx support has already stopped working.

  9. #9
    Join Date
    Sep 2007
    Posts
    80

    Default

    Does it support Kernel 2.6.29 - or ever newer?

    Greg

  10. #10
    Join Date
    Jun 2008
    Posts
    33

    Default

    Quote Originally Posted by bridgman View Post
    I think the 3xx-5xx code will get removed as time permits, so most of it is probably still in the driver today -- but since pre-6xx support is not being regression-tested and fixed as we make changes for 6xx and newer parts you should probably assume that pre-6xx support has already stopped working.
    Thanks for the answer bridgman, i can understand that, but is there any reg i can change so the new driver would allow me to load it, a force load of some kind?

    best regards

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •