Results 1 to 10 of 10

Thread: Intel Pushes Out A Big Bug-Fix X.Org Driver Update

  1. #1
    Join Date
    Jan 2007
    Posts
    13,409

    Default Intel Pushes Out A Big Bug-Fix X.Org Driver Update

    Phoronix: Intel Pushes Out A Big Bug-Fix X.Org Driver Update

    We have already burned through more than half of Q1'09 and have yet to see Intel's quarterly X.Org Linux driver update approaching (or even any release candidate, although the 2.6 release was late). While xf86-video-intel 2.7.0 isn't ready yet, a fairly significant bug-fix release has been issued in the 2.6 series. Eric Anholt has announced the release of xf86-video-intel 2.6.2, which carries some weight compared to the quick 2.6.1 release...

    http://www.phoronix.com/vr.php?view=NzA5MA

  2. #2
    Join Date
    Aug 2008
    Location
    California, USA
    Posts
    196

    Default

    Can anyone verify if all these changes happen to fix VSYNC for DRI2/UXA?

  3. #3
    Join Date
    Feb 2009
    Posts
    17

    Default

    Yeah, I would like to know as well. I have an 4500MHD and get tearing in videos with or without Compiz enabled.

  4. #4
    Join Date
    Sep 2007
    Posts
    13

    Default

    i would love to see if this fix and the upcoming 2.7.0 driver fixes the weird performance problems with Intel that we're experiencing lately. Hope to see it on Ubuntu Jaunty.

  5. #5
    Join Date
    Oct 2008
    Location
    Sweden
    Posts
    983

    Default

    Tearing isn't fixed.

  6. #6

    Default

    Has someone UXA working without problems on 965-era (GMA X-series, X3000, X3500, X4500) Intel graphics? It works okayish for me on 915, GMA 950, but not on my GMA X3000 and GMA X3100 (hangs, hard drive churn...).

  7. #7
    Join Date
    Feb 2009
    Posts
    17

    Default

    Maybe someone with more knowledge can tell me, but does this post http://lists.freedesktop.org/archive...ry/001516.html mean they found a way to stop the tearing ?

  8. #8
    Join Date
    Jun 2008
    Posts
    19

    Default

    Quote Originally Posted by Timo Jyrinki View Post
    Has someone UXA working without problems on 965-era (GMA X-series, X3000, X3500, X4500) Intel graphics? It works okayish for me on 915, GMA 950, but not on my GMA X3000 and GMA X3100 (hangs, hard drive churn...).
    I've got a X3100 and lately no problem (with UXA and KDE 4.2 with kwin effects) but I use the complete X stack directly from git so for this particular release..???

    in fact I've problems with openarena and perf in general but in both case not new...

  9. #9
    Join Date
    Oct 2008
    Location
    Sweden
    Posts
    983

    Default

    Quote Originally Posted by Timo Jyrinki View Post
    Has someone UXA working without problems on 965-era (GMA X-series, X3000, X3500, X4500) Intel graphics? It works okayish for me on 915, GMA 950, but not on my GMA X3000 and GMA X3100 (hangs, hard drive churn...).
    X4500 here, UXA is working.

    I used to have some problem with freezes but seems to be gone now.

  10. #10
    Join Date
    Oct 2008
    Location
    Sweden
    Posts
    983

    Default

    Quote Originally Posted by beecher View Post
    Maybe someone with more knowledge can tell me, but does this post http://lists.freedesktop.org/archive...ry/001516.html mean they found a way to stop the tearing ?
    This has been added to master now:

    Code:
    commit 67fef27f4b76490be085d232aba0ca9cbb3c5e59
    Author: Xiang, Haihao <haihao.xiang@intel.com>
    Date:   Fri Mar 6 09:40:07 2009 +0800
    
        Xv: free tearing on textured video
        
        Add an Xv attribute XV_SYNC_TO_VBLANK which has three values -1(auto), 0(off
        and 1(on) to control whether textured adapter synchronizes the screen
        update to the vblank. The default value is -1(auto).
    Has anyone else tried it out? It doesn't work on my G45, if anything tearing seems worse now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •