Page 6 of 13 FirstFirst ... 45678 ... LastLast
Results 51 to 60 of 130

Thread: how to get XV, DRI working on HD 3300 (rv620) ??

  1. #51
    Join Date
    Feb 2009
    Posts
    31

    Default

    Quote Originally Posted by tball View Post
    Okay interesting.
    xserver version? xorg.conf configuration?
    X.Org X Server 1.5.2
    nothing special in xorg.conf just default.

    Code:
    # /.../                                                                                                                                                                                                                                                                                                                      
    # SaX generated X11 config file                                                                                                                                                                                                                                                                                              
    # Created on: 2009-02-05T17:26:22+0200.                                                                                                                                                                                                                                                                                      
    #                                                                                                                                                                                                                                                                                                                            
    # Version: 8.1                                                                                                                                                                                                                                                                                                               
    # Contact: Marcus Schaefer <sax@suse.de>, 2005                                                                                                                                                                                                                                                                               
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>                                                                                                                                                                                                                                               
    #                                                                                                                                                                                                                                                                                                                            
    # Automatically generated by [ISaX] (8.1)                                                                                                                                                                                                                                                                                    
    # PLEASE DO NOT EDIT THIS FILE!                                                                                                                                                                                                                                                                                              
    #                                                                                                                                                                                                                                                                                                                            
    
    Section "Files"
      FontPath     "/usr/share/fonts/misc:unscaled"
      FontPath     "/usr/share/fonts/local"        
      FontPath     "/usr/share/fonts/75dpi:unscaled"
      FontPath     "/usr/share/fonts/100dpi:unscaled"
      FontPath     "/usr/share/fonts/Type1"          
      FontPath     "/usr/share/fonts/URW"            
      FontPath     "/usr/share/fonts/Speedo"         
      FontPath     "/usr/share/fonts/PEX"            
      FontPath     "/usr/share/fonts/cyrillic"       
      FontPath     "/usr/share/fonts/latin2/misc:unscaled"
      FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
      FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
      FontPath     "/usr/share/fonts/latin2/Type1"          
      FontPath     "/usr/share/fonts/latin7/75dpi:unscaled" 
      FontPath     "/usr/share/fonts/baekmuk:unscaled"      
      FontPath     "/usr/share/fonts/japanese:unscaled"     
      FontPath     "/usr/share/fonts/kwintv"                
      FontPath     "/usr/share/fonts/truetype"              
      FontPath     "/usr/share/fonts/uni:unscaled"          
      FontPath     "/usr/share/fonts/CID"                   
      FontPath     "/usr/share/fonts/ucs/misc:unscaled"     
      FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"    
      FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"   
      FontPath     "/usr/share/fonts/hellas/misc:unscaled"  
      FontPath     "/usr/share/fonts/hellas/75dpi:unscaled" 
      FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/Type1"          
      FontPath     "/usr/share/fonts/misc/sgi:unscaled"     
      FontPath     "/usr/share/fonts/xtest"                 
      FontPath     "/opt/kde3/share/fonts"                  
      InputDevices "/dev/gpmdata"                           
      InputDevices "/dev/input/mice"                        
    EndSection                                              
    
    Section "ServerFlags"
      Option       "AllowMouseOpenFail" "on"
      Option       "ZapWarning" "on"        
    EndSection                              
    
    Section "Module"
      Load         "dri"
      Load         "dbe"
      Load         "freetype"
      Load         "extmod"  
      Load         "glx"     
    EndSection               
    
    Section "InputDevice"
      Driver       "kbd" 
      Identifier   "Keyboard[0]"
      Option       "Protocol" "Standard"
      Option       "XkbLayout" "tr"     
      Option       "XkbModel" "microsoftpro"
      Option       "XkbOptions" "caps:shift"
      Option       "XkbRules" "xfree86"     
    EndSection                              
    
    
    Section "InputDevice"
      Driver       "mouse"
      Identifier   "Mouse[1]"
      Option       "Buttons" "12"
      Option       "Device" "/dev/input/mice"
      Option       "Name" "A4 Tech PS/2+USB Mouse"
      Option       "Protocol" "explorerps/2"      
      Option       "Vendor" "Sysp"                
      Option       "ZAxisMapping" "4 5"           
    EndSection                                    
    
    
    Section "Monitor"
      DisplaySize  518 324
      HorizSync    30-81  
      Identifier   "Monitor[0]"
      ModelName    "SAMSUNG SYNCMASTER"
      Option       "DPMS"              
      Option       "PreferredMode" "1920x1200"
      VendorName   "SAM"                      
      VertRefresh  43-60                      
      UseModes     "Modes[0]"                 
    EndSection                                
    
    
    Section "Modes"
      Identifier   "Modes[0]"
      Modeline      "1920x1200" 151.63 1920 2032 2240 2560 1200 1201 1204 1234
      Modeline      "1920x1200" 119.75 1920 1968 2000 2080 1200 1203 1209 1227 +HSync -Vsync
      Modeline      "1600x1200" 152.67 1600 1704 1880 2160 1200 1201 1204 1240              
      Modeline      "1600x1200" 121.25 1600 1648 1680 1760 1200 1203 1207 1232 +HSync -Vsync
      Modeline      "1280x1024" 108.88 1280 1360 1496 1712 1024 1025 1028 1060
      Modeline      "1280x1024" 89.25 1280 1328 1360 1440 1024 1027 1034 1053 +HSync -Vsync
      Modeline      "1280x960" 102.10 1280 1360 1496 1712 960 961 964 994
      Modeline      "1280x960" 83.75 1280 1328 1360 1440 960 963 967 987 +HSync -Vsync
      Modeline      "1024x768" 64.11 1024 1080 1184 1344 768 769 772 795
      Modeline      "1024x768" 55.00 1024 1072 1104 1184 768 771 775 790 +HSync -Vsync
      Modeline      "800x600" 38.22 800 832 912 1024 600 601 604 622
      Modeline      "800x600" 34.75 800 848 880 960 600 603 607 617 +HSync -Vsync
      Modeline      "1920x1200" 154 1920 1968 2000 2080 1200 1203 1209 1235 -hsync +vsync
    EndSection
    
    
    Section "Screen"
      DefaultDepth 24
      SubSection "Display"
        Depth      15
        Modes      "1920x1200" "1600x1200" "1280x1024" "1280x960" "1024x768" "800x600"
        Virtual    3840 1200
      EndSubSection
      SubSection "Display"
        Depth      16
        Modes      "1920x1200" "1600x1200" "1280x1024" "1280x960" "1024x768" "800x600"
        Virtual    3840 1200
      EndSubSection
      SubSection "Display"
        Depth      24
        Modes      "1920x1200" "1600x1200" "1280x1024" "1280x960" "1024x768" "800x600"
        Virtual    3840 1200
      EndSubSection
      SubSection "Display"
        Depth      8
        Modes      "1920x1200" "1600x1200" "1280x1024" "1280x960" "1024x768" "800x600"
        Virtual    3840 1200
      EndSubSection
      Device       "Device[0]"
      Identifier   "Screen[0]"
      Monitor      "Monitor[0]"
    EndSection
    
    
    Section "Device"
      BoardName    "ATI Radeon HD 3200 Graphics"
      Driver       "radeonhd"
      Identifier   "Device[0]"
      Option       "monitor-DVI-D_1" "Monitor[0]"
      VendorName   "ATI"
      Option        "AccelMethod"   "exa"
      Option        "DRI"   "on"
    EndSection
    
    
    
    Section "ServerLayout"
      Identifier   "Layout[all]"
      InputDevice  "Keyboard[0]" "CoreKeyboard"
      InputDevice  "Mouse[1]" "CorePointer"
      Option       "Clone" "off"
      Option       "Xinerama" "off"
      Screen       "Screen[0]"
    EndSection
    
    
    Section "DRI"
        Group      "video"
        Mode       0660
    EndSection
    
    Section "Extensions"
    EndSection
    By the way I am really impressed the development of the driver. Just one week ago it was far away from usable for me. But now it is really matured. Thanks all the devs.
    Last edited by rahman.duran; 02-09-2009 at 03:02 PM.

  2. #52
    Join Date
    Jan 2009
    Posts
    515

    Default

    Hmm weird.

    I don't got the:
    Section "DRI"
    Group "video"
    Mode 0660
    EndSection


    But thats about it.

  3. #53
    Join Date
    Feb 2009
    Posts
    31

    Default

    I have noticed image quality differences between x11 video out and xv vo on latest git( btw I dont know if it was the same before as I had never a chance to test it before ). On x11 -vo the images darker parts are darker than on xv -vo. Is it some king of gama stuf in xv code of the branch? I can post screenshots if you want.

  4. #54
    Join Date
    Feb 2009
    Posts
    31

    Default

    Quote Originally Posted by tball View Post
    Hmm weird.

    I don't got the:
    Section "DRI"
    Group "video"
    Mode 0660
    EndSection


    But thats about it.
    I dont think it is related with composite it seems it is about XV video permissions. Ofcourse I am just guessing.

  5. #55
    Join Date
    Jan 2007
    Location
    Germany
    Posts
    2,117

    Default

    Ok, I've got RadeonHD running with EXA now (with new drm and radeon modules of course) on my RV770 (had to add AccelMethod "EXA") and it is much faster than VESA, but Xv doesn't seem to be avaible, because xvinfo tells me there's no adapters present. Also interesting in the Xorg.0.log was:

    Code:
    (II) RADEONHD(0): Unknown card detected: 0x9442:0x1043:0x0264.
    	If - and only if - your card does not work or does not work optimally
    	please contact radeonhd@opensuse.org to help rectify this.
    	Use the subject: 0x9442:0x1043:0x0264: <name of board>
    	and *please* describe the problems you are seeing
    	in your message.
    (--) RADEONHD(0): Detected an RV770 on an unidentified card
    and

    Code:
    (II) RADEONHD(0): The detected amount of videoram exceeds the PCI BAR aperture.
    (II) RADEONHD(0): Using only 262144kB of the total 1048576kB.
    (--) RADEONHD(0): VideoRAM: 262144 kByte

  6. #56
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,386

    Default

    Sounds like DRI is not initialized and you're running with shadowfb.

    Do you have DRI enabled in your xorg.conf file (according to the radeonhd wiki you just need :

    Option "DRI"

    ... with no true/false value.

    Maybe pastebin your log and dmesg output ?

    EDIT - regarding the two messages you quoted :

    For the first message, "unrecognized hardware" really means "I recognize the GPU, but I don't have your specific card in my list of boards which need non-standard treatment, so I'm just going to run the normal code for your GPU". No problem.

    For the second message, that's normal as well. The PCI BARs only cover up to 256MB of address space, but modern cards have more than that. The implication is that your CPU can only easily access the first 256MB, but your GPU can use the entire memory on the card. Again, not a problem; the CPU usually only needs to access frame buffer and offscreen buffers, and occasionally a depth buffer; most of the RAM is used for textures, which are usually blitted up to video memory and accessed only by the GPU.

    Video acceleration also uses a frame cache for motion compensation, but again this information is normally only accessed by the GPU so the BAR limit is no problem.
    Last edited by bridgman; 02-09-2009 at 04:55 PM.

  7. #57
    Join Date
    Jan 2007
    Location
    Germany
    Posts
    2,117

    Default

    DRI is enabled now, but still no Xv (if xvinfo is not lying).

    Xorg.0.log
    http://pastebin.com/m72692a1c

    dmesg
    http://pastebin.com/m79ed6837

    I just booted up a openSUSE 11.1 KDE4 LiveCD and 2D performance and overall responsiveness seemed much better, even with ShadowFB. Sometimes I think Ubuntu's Xserver is just one big piece of... cake.

    Thanks for your help, bridgman & agd5f!

  8. #58
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,386

    Default

    I think you have an old version of drm. Are you building both radeonhd and drm from the 6xx-7xx branches ?

  9. #59
    Join Date
    Jan 2007
    Location
    Germany
    Posts
    2,117

    Default

    I did exactly what agd5f said. Yes, I used the r6xx-r7xx-support branch from mesa/drm, too. I replaced the modules that were in

    /lib/modules/2.6.28-something/kernel/drivers/gpu/drm/drm.ko
    /lib/modules/2.6.28-something/kernel/drivers/gpu/drm/radeon/radeon.ko

    With the newer ones...

  10. #60
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,386

    Default

    Sounds reasonable. You definitely seem to be running with an old drm, though -- dmesg output showed none of the messages (eg microcode loading) that come with the latest drm code.

    The message from your X log was :

    [0 sec: 572990 usec](EE) RADEONHD(0): RHDDRIVersionCheck: drmOpen("radeon", "pci:0000:01:00.0") failed.
    [0 sec: 573042 usec](WW) RADEONHD(0): RHDDRIPreInit: Version check failed. Disabling DRI.
    EDIT - did you reboot after updating the kernel modules ?

    Ignore my comment about the commit; you do have the right radeonhd source. Sorry.
    Last edited by bridgman; 02-09-2009 at 05:26 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •