Page 4 of 4 FirstFirst ... 234
Results 31 to 38 of 38

Thread: AMD R700 2D Driver Performance Comparison

  1. #31
    Join Date
    Aug 2008
    Posts
    16

    Default

    I've installed this driver on my Gentoo system with rv770 4850 graphic card. Performance in KDE4 apps (dolphin, plasma) is great, but only witch enabled composite (by running xcompmgr). Without composite enabled, moving windows is very slow.

    But I've noticed a problem - i can't enable XRender-based desktop effects in kwin configuration window - it displays standard dialog without any usable information (it says that activating windows effects failed). Xcompmgr works without any problems. Any ideas how to force kwin to worh with experimental r600/700 radeonhd driver? I've tried "disable functionality check" option without any success.

  2. #32
    Join Date
    Jul 2008
    Posts
    1,712

    Default

    your driver installation is borked.

  3. #33
    Join Date
    Aug 2008
    Posts
    16

    Default

    Quote Originally Posted by energyman View Post
    your driver installation is borked.
    it's not helping me or anyone.

    I know that exa acceleration is working (very fast with xcompmgr running). This is the only usable functionality of radeonhd driver from r600/700 support branch. So, if exa is working, my installation is far from broken.

    Anyone tried using this driver with kwin from kde4?

  4. #34
    Join Date
    Jul 2008
    Posts
    1,712

    Default

    oh, you are talking radeonhd ....

  5. #35
    Join Date
    Jan 2009
    Posts
    10

    Default

    if you would see my comparison test, this is the link: http://www.ech0s7.netsons.org/index.php/archives/31

    ech0s7

  6. #36
    Join Date
    Jul 2008
    Posts
    1,712

    Default

    are you use that the tests are running correctly?
    Because when run with effects turned on gtkperf seems to run faster - but it also looks like some stuff simple never got drawn. So maybe radeonhd is much faster because it does not do all the stuff it is supposed to do?

  7. #37
    Join Date
    Jan 2009
    Posts
    10

    Default

    Quote Originally Posted by energyman View Post
    are you use that the tests are running correctly?
    Because when run with effects turned on gtkperf seems to run faster - but it also looks like some stuff simple never got drawn. So maybe radeonhd is much faster because it does not do all the stuff it is supposed to do?
    Yes, i run correctly the test, and without any effect. GtkPerf not seems to run faster, it run faster! In any case, the difference is remarkable and impressive !

  8. #38
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,285

    Default

    There is still some corruption but AFAIK nothing is being skipped. Alex has the driver configured to fall back to SW rendering for anything which is seriously broken, so I think the comparison is valid.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •