Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Resizing issue with Compositing

  1. #1
    Join Date
    Jan 2009
    Posts
    4

    Default Resizing issue with Compositing

    Hello,
    I am using fglrx (8.12 8.561-1) on OpenSUSE 11.1 x86_64. My card is a Mobility Radeon HD 3650.

    When I am using compositing, both with KWin and Compiz resizing windows takes a considerably long time.

    The device section of xorg.conf looks like this:

    Section "Device"
    Identifier "Device[0]"
    Driver "fglrx"
    VendorName "ATI"
    BoardName "Mobility Radeon HD 3650"
    Option "Capabilities" "0x00000000"
    Option "OpenGLOverlay" "off"
    Option "FSAAScale" "0"
    Option "FSAAEnable" "off"
    Option "VideoOverlay" "on"
    #Option "XAANoOffscreenPixmaps" "true"
    Option "AccelMethod" "EXA"
    Option "UseFastTLS" "2"
    BusID "PCI:1:0:0"
    EndSection


    But I get this output in Xorg.0.log:

    (WW) fglrx(0): Unknown vendor-specific block f
    (WW) fglrx(0): Option "FSAAScale" is not used
    (WW) fglrx(0): Option "FSAAEnable" is not used
    (WW) fglrx(0): Option "AccelMethod" is not used
    (WW) fglrx(0): Option "CalcAlgorithm" is not used
    (WW) fglrx(0): Option "PreferredMode" is not used


    I would be most grateful for help on this.

  2. #2
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,514

    Default

    Removing the XAANoOffscreenPixmaps line might help. I don't think you want to use VideoOverlay on an HDxxxx GPU.

    Taking out the other "not used" lines won't make any difference but will make it a bit easier to see error messages.

  3. #3
    Join Date
    Jan 2009
    Posts
    4

    Default

    Quote Originally Posted by bridgman View Post
    Removing the XAANoOffscreenPixmaps line might help. I don't think you want to use VideoOverlay on an HDxxxx GPU.

    Taking out the other "not used" lines won't make any difference but will make it a bit easier to see error messages.
    Thanks for the quick response...
    The The XAANoOffscreenPixmaps line was already commented out, I commented out the VideoOverlay and that seems to have made no difference, windows still take a few seconds to resize.

  4. #4
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,798

    Default

    This is normal with ATI's drivers and there's nothing you can do about it, sorry :P You have to wait for ATI to fix the drivers (we've been waiting for a looong time though.)

  5. #5
    Join Date
    Dec 2007
    Location
    Merida
    Posts
    1,104

    Default

    I always hated how OpenSuse bloats xorg.conf. Anyway, take out the XAANoOffscreenPixmaps option as well as the VideoOverlay one. I don't think fglrx can use EXA, so you should take that out as well. You may want to take out UseFastTLS as well. This is how my xorg.conf looks like:

    Code:
    Section "Monitor"
        Identifier   "aticonfig-Monitor[0]-0"
        Option        "VendorName" "ATI Proprietary Driver"
        Option        "ModelName" "Generic Autodetecting Monitor"
        Option        "DPMS" "true"
    EndSection
    
    Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        BusID       "PCI:1:0:0"
    EndSection
    
    Section "Screen"
        Identifier "aticonfig-Screen[0]-0"
        Device     "aticonfig-Device[0]-0"
        Monitor    "aticonfig-Monitor[0]-0"
        DefaultDepth     24
        SubSection "Display"
            Viewport   0 0
            Depth     24
        EndSubSection
    EndSection


    I really don't see the need to spam the Device section with anything other than what I have there, unless you want to force a particular behavior (force opengl overlay for example). The driver will load the options it can use once you initialize it.

  6. #6
    Join Date
    Jan 2009
    Posts
    4

    Default

    Quote Originally Posted by Melcar View Post
    I always hated how OpenSuse bloats xorg.conf. Anyway, take out the XAANoOffscreenPixmaps option as well as the VideoOverlay one. I don't think fglrx can use EXA, so you should take that out as well. You may want to take out UseFastTLS as well. This is how my xorg.conf looks like:

    Code:
    Section "Monitor"
        Identifier   "aticonfig-Monitor[0]-0"
        Option        "VendorName" "ATI Proprietary Driver"
        Option        "ModelName" "Generic Autodetecting Monitor"
        Option        "DPMS" "true"
    EndSection
    
    Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        BusID       "PCI:1:0:0"
    EndSection
    
    Section "Screen"
        Identifier "aticonfig-Screen[0]-0"
        Device     "aticonfig-Device[0]-0"
        Monitor    "aticonfig-Monitor[0]-0"
        DefaultDepth     24
        SubSection "Display"
            Viewport   0 0
            Depth     24
        EndSubSection
    EndSection


    I really don't see the need to spam the Device section with anything other than what I have there, unless you want to force a particular behavior (force opengl overlay for example). The driver will load the options it can use once you initialize it.
    To be fair on OpenSUSE I added a lot of those options after looking around for solutions to the resizing issue.
    I've cleaned it up a lot now, thanks.

  7. #7
    Join Date
    Jan 2009
    Posts
    4

    Default

    Quote Originally Posted by RealNC View Post
    This is normal with ATI's drivers and there's nothing you can do about it, sorry :P You have to wait for ATI to fix the drivers (we've been waiting for a looong time though.)
    I had a feeling that that was going to be the case. Thanks for the confirmation.

  8. #8
    Join Date
    Jan 2009
    Posts
    24

    Default

    still an issue in 9.7...

  9. #9
    Join Date
    Jun 2008
    Location
    New Zealand
    Posts
    68

    Default

    From what I've seen it is more of a bug in X, just that the slowness is noticed on ATI more. Even on Nvidia, try to resize some of the gnome games, most noticeably gbnibbles, and you will see the exact symptoms that fglrx has on other windows when the backfill functionality is there. Note that, resizing gnibbles is slow regardless of whether the patch is applied or not, implying that the problem is not in the backfill function itself, but that it just exposes a deeper issue.

  10. #10
    Join Date
    Dec 2007
    Location
    Merida
    Posts
    1,104

    Default

    The patched xserver that has been floating around fixes this issue, but the downside is that you get artifacts on-screen.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •