Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Radeon HD 2400 HDMI Audio working, kind of...

  1. #1
    Join Date
    Sep 2008
    Posts
    5

    Default Radeon HD 2400 HDMI Audio working, kind of...

    I have been working on a mythbuntu install for several weeks with varying degrees of success. I have installed and reinstalled mythbuntu 8.04 several times and I think I have it down now. I have been installing connected to my Vizio VW26L HDTV using a 6ft hdmi cable. Sound works fine over HDMI after several tweeks. When I put the tv in the bedroom and the computer in the closet and connect via a 50ft cable I lose all stability. With the stock fglrx drivers from 8.04 the screen would flicker and sometimes lose signal. But the sound worked. I have since downloaded and installed the catalyst 8.9 fglrx, got sound working and hardcoded my modelines. Now I can keep the video sync'd, but no sound. aticonfig yields the following:

    myth1:~$ aticonfig --query-connectortype tmds2i
    connector type: DVI-I .

    I read on one forum or another that the sound might not work because fglrx thinks the card is connected to a DVI device. I have not tried this command with the sound working so I don't know what it would report.

    Should aticonfig --query-connectortype tmds2i be reporting 'HDMI' for me to get sound? If so, can I force it to HDMI? I am confident that I can reinstall and get it all working in about 30minutes with the shorter cable. Before I go and spend a bunch of $$$ on high end cables and associated signal conditioners I would like to know why forcing a specific modeline and starting mythtv with a specific geometry (1366x768) gives me stable video but no audio.

    Thanks in adavance.

  2. #2
    Join Date
    Sep 2006
    Posts
    353

    Default

    Quote Originally Posted by mythms View Post
    I have been installing connected to my Vizio VW26L HDTV using a 6ft hdmi cable.
    I have been installing connected to my Vizio VW26L HDTV using a 6ft hdmi cable.

    Please boot into the console and run the command startx -- -logverbose 6 to start X. Then post the file /var/log/Xorg.0.log (the EDID information) on this thread.

    This will probably help a lot of folk set up X.

    Thanks a lot Jade.

  3. #3
    Join Date
    Sep 2008
    Posts
    5

    Default /var/log/Xorg.0.log and /etc/X11/xorg.conf

    I work on this system primarily through ssh and vnc. I don't know how to get console access without hooking up a keyboard and mouse so I edited /usr/bin/startx as follows:

    /usr/bin/startx was:
    serverargs=""
    now:
    serverargs="-logverbose 6"

    However the /var/log/Xorg.0.log doesn't appear much different than what I am used to. My /etc/X11/xorg.conf is given below

    Regarding my original post:
    Immediately after reboot I get the following:

    myth1:~$ aticonfig --query-connectortype tmds2i
    connector type: DVI-I .

    Then I selected 'Watch TV' and sound was working. (Currently connected through a 6ft HDMI/HDMI cable using the ATI DVI/HDMI adapter.)

    When I executed 'aticonfig --query-connectortype tmds2i' again I get:

    connector type: HDMI A .

    This seems to confirm my original suspicion that the card is unable to negotiate the HDMI setting through the 50ft cable. My xorg.conf settings (below), specifically the 1368x768 Modeline, give me HD video. I need a way to force the connectortype to 'HDMI A'. Anybody?

    Regarding the Modeline:
    Page 25 of the Vizio VW26L manual gives '1366 x 768 @60HZ' as the proper timing for the monitor when connected through the RGB connector. However gtf yeilds:

    %> gtf 1366 768 60

    # 1368x768 @ 60.00 Hz (GTF) hsync: 47.70 kHz; pclk: 85.86 MHz
    Modeline "1368x768_60.00" 85.86 1368 1440 1584 1800 768 769 772 795 -HSync +Vsync

    I found that the trick to getting mythtv to work was to pass the correct geometry to mythtv on the command line. This required two different modifications:

    Modify lines at the bottom of /usr/share/mythtv/mythfrontend.sh as follows:

    #Doesn't properly handle settings in /etc/mythtv/session-settings:
    exec /usr/bin/mythfrontend.real "$@"

    Change to:

    #Handles settings in /etc/mythtv/session-settings:
    exec /usr/bin/mythfrontend.real $@

    Then modify /etc/mythtv/session-settings as follows:

    # MYTHFRONTEND_OPTS="--verbose all,nodatabase"
    MYTHFRONTEND_OPTS="--geometry 1366x768"


    Another note about xorg.conf below. aticonfig has commented out my 'ForceMonitors' line since I unhooked my 50ft cable and reconnected via the 6ft cable.


    /etc/X11/xorg.conf:
    Code:
    joey@myth1:/var/lib/mythtv/videos$ cat /etc/X11/xorg.conf
    
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "ServerLayout"
      Identifier     "Default Layout"
      Screen      0  "aticonfig-Screen[0]-0" 0 0
    EndSection
    
    Section "Files"
    EndSection
    
    Section "Module"
      Load  "glx"
    EndSection
    
    Section "InputDevice"
      Identifier  "Generic Keyboard"
      Driver      "kbd"
      Option            "XkbRules" "xorg"
      Option            "XkbModel" "pc105"
      Option            "XkbLayout" "us"
    EndSection
    
    Section "InputDevice"
      Identifier  "Configured Mouse"
      Driver      "mouse"
      Option            "CorePointer"
    EndSection
    
    Section "Monitor"
      Identifier   "aticonfig-Monitor[0]-0"
      ModeLine     "1368x768_60.00" 85.9 1368 1440 1584 1800 768 769 772 795 -hsync +vsync
      ModeLine     "1360x768_60.00" 84.7 1360 1424 1568 1776 768 769 772 795 -hsync +vsync
      ModeLine     "1024x768_60.00" 64.1 1024 1080 1184 1344 768 769 772 795 -hsync +vsync
      Option            "VendorName" "ATI Proprietary Driver"
      Option            "ModelName" "Generic Autodetecting Monitor"
    # Option            "DPMS" "true"
      Option            "DPMS" "false"
    EndSection
    
    Section "Device"
    
    # Option            "EnableMonitor" "crt1,lvds,tv,tmds1,crt2,tmds2,cv,tmds2i"
    # Option            "EnableMonitor" "crt1,lvds,tv,tmds1,crt2,tmds2,cv,tmds2i"
    # Option            "ForceMonitors" "tmds2"
      Identifier  "aticonfig-Device[0]-0"
      Driver      "fglrx"
      Option            "TexturedVideo" "true"
      Option            "VideoOverlay" "on"
      Option            "OpenGLOverlay" "off"
    # Option            "ForceMonitors" "crt2,tmds2i"
      Option            "EnableMonitor" "crt1,lvds,tv,tmds1,crt2,tmds2,cv,tmds2i"
      BusID       "PCI:1:0:0"
    EndSection
    
    Section "Screen"
      Identifier "aticonfig-Screen[0]-0"
      Device     "aticonfig-Device[0]-0"
      Monitor    "aticonfig-Monitor[0]-0"
      DefaultDepth     24
      SubSection "Display"
    
    #       Modes    "1366x768" "1600x1200" "1280x1024" "1024x768"
    #       Modes    "0x0"
            Viewport   0 0
            Depth     24
            Modes    "1368x768_60.00" "1360x768_60.00" "1024x768_60.00"
      EndSubSection
    EndSection

  4. #4
    Join Date
    Sep 2006
    Posts
    353

    Default

    Thanks mythms, but the xorg.conf file is almost irrelevant here.

    You need the information from /var/log/Xorg.0.log

    Get the main EDID information section and also the "Validating Modes" section (just report the ones labeled "Mode Source: EDID"):

    These sections look like this

    Code:
     EDID Version                 : 1.3
     Manufacturer                 : PHL
     Monitor Name                 : Philips 170S
     Product ID                   : 2078
     32-bit Serial Number         : 693129
     Serial Number String         :  CF  693129
     Manufacture Date             : 2003, week 32
     DPMS Capabilities            : Standby Suspend Active Off
     Prefer first detailed timing : Yes
     Supports GTF                 : No
     Maximum Image Size           : 340mm x 270mm
     Valid HSync Range            : 30.0 kHz - 82.0 kHz
     Valid VRefresh Range         : 56 Hz - 76 Hz
     EDID maximum pixel clock     : 140.0 MHz
    Code:
     Validating Mode "1280x1024":
       1280 x 1024 @ 60 Hz
       Mode Source: EDID
         Pixel Clock      : 108.00 MHz
         HRes, HSyncStart : 1280, 1328
         HSyncEnd, HTotal : 1440, 1688
         VRes, VSyncStart : 1024, 1025
         VSyncEnd, VTotal : 1028, 1066
         H/V Polarity     : +/+
       Mode is valid.
     
     Validating Mode "1280x960":
       1280 x 960 @ 60 Hz
       Mode Source: EDID
         Pixel Clock      : 108.00 MHz
         HRes, HSyncStart : 1280, 1376
         HSyncEnd, HTotal : 1488, 1800
         VRes, VSyncStart :  960,  961
         VSyncEnd, VTotal :  964, 1000
         H/V Polarity     : +/+
       Mode is valid.
     
     Validating Mode "1152x864":
       1152 x 864 @ 70 Hz
       Mode Source: EDID
         Pixel Clock      : 96.76 MHz
         HRes, HSyncStart : 1152, 1224
         HSyncEnd, HTotal : 1344, 1536
         VRes, VSyncStart :  864,  865
         VSyncEnd, VTotal :  868,  900
         H/V Polarity     : -/+
       Mode is valid.
    I work on this system primarily through ssh and vnc.
    Why would you do that. You are just using the Vizio VW26L as a monitor, so the console is the usual console (ie the console on the computer you are using, the computer connected to the Vizio VW26L monitor).
    Last edited by Jade; 09-28-2008 at 09:55 PM.

  5. #5
    Join Date
    Sep 2008
    Posts
    5

    Default link to Xorg.0.log is in previous post...

    It was too large to include in the post.

    As to the vnc/ssh connection, my MythTV lives in a closet and I don't have a nice comfy chair in there

  6. #6
    Join Date
    Sep 2006
    Posts
    353

    Default

    Quote Originally Posted by mythms View Post
    It was too large to include in the post.

    As to the vnc/ssh connection, my MythTV lives in a closet and I don't have a nice comfy chair in there
    No,... it is not too large,... just post it.
    Chop it up (into many posts) if need be.


    Does the computer you run ssh from live in the closet as well?

    Actually I don't understand your setup. You seem to have two boxes. One you ssh from and a headless(?) computer you ssh to. But this doesn't make any sense, so maybe you can explain the setup.

    mythms: Thanks for the answer in the next post:

    Any reason for not starting X with startx -- -logverbose 6 to create your Xorg.0.log? Note the 6. You can also use any number greater than 6. It appears that you have used 5. Although,....

    I guess it is possible that some X-saboteurs (similar folk to the well known kernel saboteurs) may have rewritten the X-server recently to report far less information (than the version I am using) and in an obscured (ie hex) format. This would be expected (at some point).
    Last edited by Jade; 09-30-2008 at 07:52 PM.

  7. #7
    Join Date
    Sep 2008
    Posts
    5

    Default My setup

    Jade,

    My current Xorg.0.log is over 100K. Maximum post length is 10000 characters, SO, rather than split it up over 10 separate posts. I went to the trouble to put it on my webserver, even created a tinyurl to simplify. Here's the link again, /var/log/Xorg.0.log.

    One could infer from your red font and ellipsis, a snide and condescending tone. Since I'm usually not disposed to go very far out of my way to interact with a smart@$$, even one who might be of some assistance, I will assume that you didn't mean it that way. Perhaps you just like the color red and the ...'s stood in place of a glowing complements. If so please forgive my oversensitivity.

    Where were we...

    Setup(no sound)
    -------
    [XP PC] in office
    |
    |
    <ethernet>
    |
    |
    [mythbuntu] in closet
    |
    |
    <50ft HDMI Cable>
    |
    |
    [Visio HDTV in Bedroom]


    Setup(w/ sound)
    [XP PC] in office (with nice place to sit)
    |
    |
    <ethernet>(ssh,vnc)
    |
    |
    [mythbuntu] in bedroom (with no good place to use keyboard and mouse)
    |
    <6ft HDMI>
    |
    [Visio HDTV] in bedroom



    Alternate Setup (so I don't have to sit on the floor with keyboard and mouse)
    [laptop] in bedroom
    |
    |
    <wifi>(ssh,vnc)
    |
    |
    [Router]
    |
    |
    <ethernet>
    |
    |
    [mythbuntu]
    |
    |
    <6ft hdmi>
    |
    |
    [Vizio HDTV]

  8. #8
    Join Date
    Sep 2008
    Posts
    1

    Default

    As far as I know I've only sound throught HDMI in the real HDready 1280x720 resolution not in 1360x768 :/

  9. #9
    Join Date
    Sep 2008
    Posts
    5

    Default Sound works fine @1366x768 with 6ft cable

    Quote Originally Posted by boubou91 View Post
    As far as I know I've only sound throught HDMI in the real HDready 1280x720 resolution not in 1360x768 :/
    Sound is working fine when connected through 6ft cable. Only have trouble with 50ft cable. Monitor reports 1366x768@60HZ too. X desktop, however, doesn't like 1366x768@60. X desktop will only allow 1368x768@60 and 1360x768@60. Have to pass the 1366x768 to mythtfrontend on the command line (see post above for description). I have configured the 'Power' button on my Hauppage remote to start mythfrontend if it is not running and to killall mythfrontend if it is. Through this start/stop process the x-desktop and mythfrontend switch back and forth between resolutions without hiccups.

    I've yet to figure out how to pass the 1366x768 geometry parameter to the mythtv-setup so backend configuration screens are scrambled. If I connect via vnc the mythtv-setup screen is correctly formatted. That is how I am working around it until I have time to track down the command line issues.

  10. #10
    Join Date
    Aug 2007
    Posts
    6,646

    Default

    @mythms

    try 1360x768, because native res is 1366 wide of course you get a small black boarder left+right. 1368 is too big.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •