I installed PTS 1.2 on Kubuntu Gutsy (7.10) using the .deb installer
(dpkg -i [PTS].deb)

It appeared to install ok and I was able to launch it from the cli (terminal), and select a module I wanted to see, Unigine Tropics. It downloaded and installed it. When I tried to run it, however, it showed numerous missing dependencies.

So I manually (through synaptic) search for, found, and installed the missing dependencies. PTS will still not run unigine tropics, however.

So just to see if PTS will run anything, I installed the opengl-demo module and tried to run that. Same thing: slew of missing dependencies, manually installed 'em all, still won't run

Here is the result of phoronix-test-suite system-info:
Phoronix Test Suite v1.2.2 (MALVIK)
System Information

Processor: AMD Athlon Dual Core 4850e @ 2.50GHz (Total Cores: 2), Motherboard: MSI CO. LTD MS-7312, Chipset: VIA K8M800 Host Bridge, System Memory: 2026MB, Disk Space: 23GB, Graphics: ATI RV350 AS, Screen Resolution: 1280x1024

OS: Ubuntu 7.10, Kernel: 2.6.22-15-generic (i686), X.Org Server: 1.3.0, OpenGL: 2.1.7412 (fglrx), Compiler: GCC 4.1.3, File-System: ext2/ext3
Incidentally my grafics card is a Sapphire ATI 9550 128MB AGP, and I'm using the Catalyst 8.47.3 drivers. Everything looks kosher in glxinfo, and I'm getting ~1500 fps in glxgears.

Can anyone tell me what is wrong? There seems to be a distinct lack of easily-accessible documentation for this software. The Man pages tell next to nothing except a handful of commands. Nowwhere can I find any info on minimum system requirements, trouble-shooting etc.

Thanks for any help!