Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: bad video quality with ati proprietary linux driver : solution?

  1. #1
    Join Date
    Aug 2008
    Location
    Dijon, France
    Posts
    15

    Default Bad video quality with ATI/AMD proprietary linux driver (pixely rendering)

    Hello everyone,

    Could someone give me THE good solution to improve video quality with all software? I know it deals with overlay or something like that but I'm tired to look for the good configuration. I'm sorry, I'm not so lazy usually!
    The computer I'm configuring : Radeon Mobility 3650 512mo, Ubuntu Hardy.

    Thank you!

    Rémi.
    Last edited by remjg; 08-23-2008 at 02:11 PM.

  2. #2
    Join Date
    Aug 2008
    Location
    Dijon, France
    Posts
    15

    Default

    I've tried the 2 following options but it doesn't work :
    - sudo aticonfig -ovt=Xv ("VideoOverlay" "on" and "OpenGLOverlay" "off")
    - sudo aticonfig -ovt=opengl ("VideoOverlay" "off" and "OpenGLOverlay" "on")

    I've also changed the default video output module in VLC but nothing works (I've disabled Compiz for testing the opengl video output module).

  3. #3
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,458

    Default

    Video Overlay was mostly removed starting with the X1xxx products. You want to use Textured Video.

    What problem(s) were you trying to fix in the first place ?

  4. #4
    Join Date
    Aug 2008
    Location
    Dijon, France
    Posts
    15

    Default

    When I play a video, I see "a lot of pixels" (with every player).
    Video playback is poor... It's not smooth! And yet I'm using linear deinterlaced option.
    I'm sorry it's difficult for me to explain my problem in English!

    Here is a capture of my screen when I made pause :
    http://dl.free.fr/jp9g0H3oO

    And Here is a capture during video playback :
    http://dl.free.fr/qz6UgZzbT


    I've the same problem on my own computer (with ATI X700) and I use the ati open-source driver to avoid that.
    Here is the /etc/X11/xorg.conf file of the computer I'm configuring :
    Code:
    stef@stephanie-acer8920:~$ cat /etc/X11/xorg.conf
    
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "ServerLayout"
    	Identifier     "Default Layout"
    	Screen         "Default Screen" 0 0
    	InputDevice    "Synaptics Touchpad"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "Module"
    	Load  "glx"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Generic Keyboard"
    	Driver      "kbd"
    	Option	    "XkbRules" "xorg"
    	Option	    "XkbModel" "pc105"
    	Option	    "XkbLayout" "fr"
    	Option	    "XkbVariant" "oss"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Configured Mouse"
    	Driver      "mouse"
    	Option	    "CorePointer"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Synaptics Touchpad"
    	Driver      "synaptics"
    	Option	    "SendCoreEvents" "true"
    	Option	    "Device" "/dev/psaux"
    	Option	    "Protocol" "auto-dev"
    	Option	    "HorizEdgeScroll" "0"
    EndSection
    
    Section "Monitor"
    	Identifier   "Configured Monitor"
    EndSection
    
    Section "Device"
    	Identifier  "Configured Video Device"
    	Driver      "fglrx"
    	Option	    "VideoOverlay" "on"
    	Option	    "OpenGLOverlay" "off"
    EndSection
    
    Section "Screen"
    	Identifier "Default Screen"
    	Device     "Configured Video Device"
    	Monitor    "Configured Monitor"
    	DefaultDepth     24
    EndSection
    Perhaps you will see an option missing...
    Last edited by remjg; 08-27-2008 at 10:56 AM.

  5. #5
    Join Date
    Aug 2008
    Location
    Dijon, France
    Posts
    15

    Default

    Quote Originally Posted by bridgman View Post
    You want to use Textured Video.
    How can I enable "Textured Video" with aticonfig?

    Is there a link between "Textured Video" and the "--sync-video" and "--vs" options of aticonfig?

    Could you give me a link that explain me what are "Textured Video" and "Video Overlay" and how configure it?

  6. #6
    Join Date
    Dec 2007
    Location
    Merida
    Posts
    1,100

    Default

    TexturedVideo should be on by default with your particular card; check xorg.0.log to make sure. If you want, you can still force the option simply by adding...

    Code:
    Option    "TexturedVideo"   "on"
    ... to the Device section of your xorg.conf.

  7. #7
    Join Date
    Aug 2008
    Location
    Dijon, France
    Posts
    15

    Default Thank you very much! It works :)

    Hi Melcar!

    I've checked my /var/log/Xorg.0.log file and I haven't seen anything about TexturedVideo!
    Therefore, I've add the following line in my /etc/X11/xorg.conf file in the section Device as you told me :
    Code:
    Option    "TexturedVideo"   "on"
    And it seems to be much better on my computer (with a X700 mobility)! Nevertheless, I don't see any line about texturedVideo in the Xorg log file... but it works! Thank you very much for your help! It was so ugly that I was using the ati opensource driver since 2 years... And I will go on using it! But it's nice for my friends/family who are using Ubuntu!

    I will try on my girlfriend's laptop (with a HD3650) as soon as possible.

    Do you know why TexturedVideo is not by default? Video playback is often more important that 3D acceleration... I already use Ubuntu Hardy Heron 8.04.
    Last edited by remjg; 09-04-2008 at 10:13 PM.

  8. #8
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,458

    Default

    The X700 was the last generation of GPUs (R4xx) which had significant video processing hardware in the overlay block. The overlay uses less CPU than Textured Video, so it's the "safest" option and that's where we default on R4xx and lower.

    Starting with R5xx (aka X1xxx) the video processing was largely removed from the overlay block (we used the space for more shader power) so Video Overlay is not an option. On the newer GPUs we default to Textured Video.

  9. #9
    Join Date
    Oct 2007
    Location
    Roanoke, VA
    Posts
    228

    Default

    Quote Originally Posted by bridgman View Post
    Starting with R5xx (aka X1xxx) the video processing was largely removed from the overlay block (we used the space for more shader power) so Video Overlay is not an option. On the newer GPUs we default to Textured Video.
    On that topic, bridgman... is there any chance of ATI releasing a card that is oriented toward high quality 2D and high quality video playback, instead of 3D rendering? Is there a particular ATI card that is "best" for video playback under Linux?

  10. #10
    Join Date
    Oct 2007
    Location
    Roanoke, VA
    Posts
    228

    Default

    Update -
    I switched to a recent build of the open source (radeon) driver as part of upgrading to Intrepid Ibex Alpha 5 yesterday, and the 2D and video performance seem better than using fglrx... at least on my Thinkpad T60 with X1400 (RV515) with EXA enabled, AccelDFS on, and DMAForXv on. Xv implementation is definitely better... there are more ports available and media applications can autoconfigure to Xv, unlike under fglrx 8.7 when I had to explicitly specify an Xv port.

    It looks like Bridgman has been talking good sense when he has recommended the open source drivers for those who doesn't need the advanced 3D performance specifically. It's truly a more simple solution, and one that seems more tightly integrated with the OS, at least in Ubuntu.
    Last edited by Porter; 09-08-2008 at 01:17 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •