Results 1 to 3 of 3

Thread: Qt5 Will Now Support LGPLv3 Modules

  1. #1
    Join Date
    Jan 2007
    Posts
    15,130

    Default Qt5 Will Now Support LGPLv3 Modules

    Phoronix: Qt5 Will Now Support LGPLv3 Modules

    With the upcoming Qt 5.4 release, LGPLv3 is now an optional license alongside the existing LGPLv2.1 license and the commercial combination for Qt Enterprise...

    http://www.phoronix.com/vr.php?view=MTc2ODI

  2. #2
    Join Date
    Feb 2011
    Posts
    1,243

    Default

    There is also this:
    http://www.olafsw.de/protecting-soft...icense-update/

    At the same time, Digia has agreed to work with us on three improvements for our contract:

    The contract will include the other desktop and mobile platforms (Windows, Mac, iOS and WinRT) for as long as Qt has support for running on them.

  3. #3
    Join Date
    Jun 2014
    Posts
    32

    Default

    I like this.

    If you want to use Qt, you must support it in some way. Either pay for it, and then you can create whatever proprietary software you want. Or you use the free version, but that means you are restricted to the non-buggy LGPL3, so you can't prevent your users from hacking on at least the bundled Qt libs. Which appears to be a pretty small trade-off considering you get a very powerful toolkit for free.

    And I love that Digia works with KDE to ensure Qt's position in the free software community stays as important as it is today.

    Too bad LGPL2 is still in use and has that tivoization issue, but I realize that by no longer using that license, there may be issues with incompatible free software licenses etc..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •