Hi,

What's the state of the LLVM backend? It's the only one that supports GLSL 1.5 and hence provides full GL 3.3 support.

Also does the driver needs to be recompiled or can it be enabled another way? (I'm using the Xorg edgers PPA)