Hi.
This is my first post on these forums. First, I would like to say, that I have found many useful information here. Keep up good work.
Now, this may not be exactly the right thread, but I thought it might be appropriate.

I have Asus laptop with optimus, both Intel and nvidia graphic cards. I have Ubuntu 14.04 64bit with 3.13.0-30-generic. No matter what, I cannot seem to manage to get VDPAU to work. I use Intel card most of the time, and I would need nvidia card for watching HD videos with mplayer. This is (for now) the only thing I need it for. I installed bumblebee, which works fine, using nvidia-319 proprietary drivers (probably others too, might even work good with nouveau). Is there someone, who can help me to install VDPAU? I don't care if it means compiling source, switching cards using only command line, installing w/e drivers. I just want to know how to do it. If you have any better solution than VDPAU, that is also great. For now, mplayer uses about 60% of CPU, which I don't like. I believe I need to install libvdpau1 vdpau-va-driver. Anything else? Do I need to configure it somehow?

Some info:
optirun lshw -c video
Code:
*-display               
       description: VGA compatible controller
       product: GK107M [GeForce GT 650M]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:48 memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:f7000000-f707ffff
  *-display
       description: VGA compatible controller
       product: 3rd Gen Core processor Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:43 memory:f7400000-f77fffff memory:d0000000-dfffffff ioport:f000(size=64)
vdpauinfo
Code:
display: :0   screen: 0
Failed to open VDPAU backend libvdpau_i965.so: cannot open shared object file: No such file or directory
Error creating VDPAU device: 1
optirun glxsphears64
Code:
Polygons in scene: 62464
Visual ID of window: 0x20
Context is Direct
OpenGL Renderer: GeForce GT 650M/PCIe/SSE2
259.848030 frames/sec - 289.990402 Mpixels/sec
270.727066 frames/sec - 302.131405 Mpixels/sec
269.365841 frames/sec - 300.612278 Mpixels/sec
mplayer -vo vdpau videofile
Code:
Failed to open VDPAU backend libvdpau_i965.so: cannot open shared object file: No such file or directory
[vdpau] Error when calling vdp_device_create_x11: 1
ll ll /usr/lib/x86_64-linux-gnu/vdpau/
Code:
drwxr-xr-x   2 root root  4096 jul 10 20:28 ./
drwxr-xr-x 112 root root 69632 jul 10 20:37 ../
lrwxrwxrwx   1 root root    23 avg 16  2013 libvdpau_trace.so.1 -> libvdpau_trace.so.1.0.0
-rw-r--r--   1 root root 51224 avg 16  2013 libvdpau_trace.so.1.0.0
/usr/lib/vdpau is empty.
As you can see, both want to use intel's module for vdpau. If do VDPAU_DRIVER=nvidia in from, I get the same error, except with _nvidia instead of _i965.

If you can help me (you can send me PM if you don't want to spam here) or if you need any other information, please say so.