Results 1 to 9 of 9

Thread: ALSA 1.0.28 Released

  1. #1
    Join Date
    Jan 2007
    Posts
    14,824

    Default ALSA 1.0.28 Released

    Phoronix: ALSA 1.0.28 Released

    A new update to the Advanced Linux Sound Architecture (ALSA) is finally available...

    http://www.phoronix.com/vr.php?view=MTcyMjY

  2. #2
    Join Date
    Sep 2008
    Location
    Vilnius, Lithuania
    Posts
    2,554

    Default

    No ctxfi improvements. Sigh.

  3. #3
    Join Date
    May 2007
    Location
    Third Rock from the Sun
    Posts
    6,584

    Default

    Quote Originally Posted by GreatEmerald View Post
    No ctxfi improvements. Sigh.
    They have done about as much as they can do with the slim amount of documentation that creative provided.

  4. #4
    Join Date
    Feb 2008
    Location
    Santiago, Chile
    Posts
    242

    Default

    Quote Originally Posted by deanjo View Post
    They have done about as much as they can do with the slim amount of documentation that creative provided.
    I still miss how things were in the past with Creative Labs. They used to have a management who cared about open source, but after the Audigys, that changed.

    Owner of the last Creative Labs sound card fully supported under Linux, the Sound Blaster Live!.

  5. #5
    Join Date
    Sep 2013
    Posts
    30

    Default

    Quote Originally Posted by GreatEmerald View Post
    No ctxfi improvements. Sigh.
    And CA0132 (Recon3D and SB Z).

  6. #6
    Join Date
    May 2010
    Posts
    89

    Default

    Quote Originally Posted by marciocr View Post
    And CA0132 (Recon3D and SB Z).
    And ironically this should be the easier to support because they are just hda intel codec cards with a dsp.

    Windows have sound with this cards without any creative driver installed, you just can't play with dsp effects.

    This shows how bad linux sound support is, when a basic hda intel cards doesn't function right.

    Also Creative support is pretty horrible and they don't care about linux and their users.

  7. #7
    Join Date
    Oct 2012
    Location
    Sweden
    Posts
    307

    Default

    I have a Creative SB X-Fi Titanium, and the microphone doesn't work. It also doesn't mute the speakers when I plug in headphones. These are simple, very expected things.
    I'm probably moving to an Asus Xonar of some kind in the future.

  8. #8
    Join Date
    Oct 2007
    Posts
    1,277

    Default

    Quote Originally Posted by GreatEmerald View Post
    No ctxfi improvements. Sigh.
    This is only ALSA userspace changes. The stuff you want is probably at kernel level: https://github.com/torvalds/linux/tree/master/sound/pci

  9. #9
    Join Date
    Sep 2008
    Location
    Vilnius, Lithuania
    Posts
    2,554

    Default

    Quote Originally Posted by DanL View Post
    This is only ALSA userspace changes. The stuff you want is probably at kernel level: https://github.com/torvalds/linux/tree/master/sound/pci
    I'm not really certain whether the issues (for instance, a high-pitched chirp every time PulseAudio starts) are at kernel or userland level... And the kernel seems to have just one commit that actually fixes something ever since version 3.6. :\

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •