Page 7 of 8 FirstFirst ... 5678 LastLast
Results 61 to 70 of 77

Thread: Catalyst 14.4 Has Advantages Over Linux 3.15 + Mesa 10.3 Git

  1. #61

    Default

    Quote Originally Posted by dungeon View Post
    Yep i can confirm that issue with 0AD, just installed it. It is not even maxed out i leaved it to default and just enable postprocessing and yes all is black .

    And when i select Smooth LOS game just segfaults .
    alpha16 new graphics options are a bit bugged. You should restart the game after changing graphics options.

  2. #62
    Join Date
    Feb 2008
    Posts
    908

    Default

    Quote Originally Posted by oibaf View Post
    alpha16 new graphics options are a bit bugged. You should restart the game after changing graphics options.
    Yep game immediately segfault when i check that option, but not when i am in start menu Of course that is workaround with Smooth LOS, but postprocessing remains black whatever or how i set it.

    Spotted blackiness in Unigine Sanctuary today too, i don't know how Michel can benchmark that driver when rendering is so broken . Who cares if fps is faster when rendering is broken

    Last edited by dungeon; 05-20-2014 at 03:11 PM.

  3. #63
    Join Date
    Jun 2009
    Posts
    1,124

    Default

    Quote Originally Posted by dungeon View Post
    Yep game immediately segfault when i check that option, but not when i am in start menu Of course that is workaround with Smooth LOS, but postprocessing remains black whatever or how i set it.

    Spotted blackiness in Unigine Sanctuary today too, i don't know how Michel can benchmark that driver when rendering is so broken . Who cares if fps is faster when rendering is broken

    well in my 7700 since llvm 3.5 this issue dont happen to me in any unigine demo anymore and yes oibaf is right if i restart the game with all options active it works just fine for me, the issue is just when you switch them in realtime, llvm 3.5 also fix some weirdness in Civ5 BnW under wine i had with old LLVM stack. Also i noticed that my 7700 dont slowdown either with 3.15 kernel + PTE patches compared to 3.14, so i guess many of this radeonsi issue apply mostly to GCN 1.1+ hardware.

    in my case the only bug i seen affecting my GCN 1.0 card is you truck game trace

  4. #64
    Join Date
    Feb 2008
    Posts
    908

    Default

    Quote Originally Posted by jrch2k8 View Post
    well in my 7700 since llvm 3.5 this issue dont happen to me in any unigine demo anymore
    I've tried yesterday llvm 3.5 git too, but that is with llvm3.4.1... can you post screenshot how Unigine Sanctuary there looked like for you? Do you compared that with llvmpipe or fglrx render? .

  5. #65
    Join Date
    Feb 2008
    Posts
    908

    Default

    Quote Originally Posted by dungeon View Post
    I've tried yesterday llvm 3.5 git too, but that is with llvm3.4.1... can you post screenshot how Unigine Sanctuary there looked like for you? Do you compared that with llvmpipe or fglrx render? .
    Nope, just rebuilded mesa against llvm3.5-svn209039 the same issue in Sanctuary .

    So jrch2k8 did you compare it against swrast or fglrx, do you have that half black wall, missing lighting from windows, etc

    This is how it looks like with fglrx

    Last edited by dungeon; 05-20-2014 at 07:16 PM.

  6. #66
    Join Date
    Feb 2011
    Location
    Ukraine
    Posts
    132

    Default

    Quote Originally Posted by dungeon View Post
    I've tried yesterday llvm 3.5 git too, but that is with llvm3.4.1... can you post screenshot how Unigine Sanctuary there looked like for you? Do you compared that with llvmpipe or fglrx render? .
    hd 7790 (llvm\mesa git) and intel hd 2500


  7. #67
    Join Date
    Feb 2011
    Location
    Ukraine
    Posts
    132

    Default

    Quote Originally Posted by dungeon View Post
    I've tried yesterday llvm 3.5 git too, but that is with llvm3.4.1... can you post screenshot how Unigine Sanctuary there looked like for you? Do you compared that with llvmpipe or fglrx render? .

  8. #68
    Join Date
    Feb 2008
    Posts
    908

    Default

    Much thanks Pontostroy for the screenshot and the video. Swrast and intel driver behave OK there, but as you can see on radeonsi all shadows are broken, darker, missing and missplaced .

  9. #69
    Join Date
    Jul 2012
    Posts
    149

    Default

    How to run this utility after unpacked it?

  10. #70
    Join Date
    Feb 2008
    Posts
    908

    Default

    Quote Originally Posted by Azrael5 View Post
    How to run this utility after unpacked it?
    Just run a script Sanctuary is 32bit so if you use 64bit OS you will need 32bit graphics stack installed too, and which one that will be of course depends on the driver you use .

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •