Why not take latest development edition for openSolaris? snv 112 included in Solaris express edition, for example.