Yes, that's true. fglrx driver for Xserver 1.13 support is already available in Ubuntu 12.10 repository.