Search:

Type: Posts; User: airlied; Keyword(s):

Page 1 of 5 1 2 3 4

Search: Search took 0.14 seconds.

  1. Replies
    9
    Views
    1,968

    That line I quoted. What does "fully beyond the...

    That line I quoted. What does "fully beyond the GLSL requirements" mean, mentioning that llvmpipe supports GL 3.3 fully beyond GLSL requirements, where he is comparing llvmpipe to softpipe. Does it...
  2. Replies
    9
    Views
    1,968

    "For a while now, LLVMpipe has supported OpenGL...

    "For a while now, LLVMpipe has supported OpenGL 3.3 fully beyond just the GL Shading Language requirements,"

    Reading is hard.

    Dave.
  3. Replies
    9
    Views
    1,968

    softpipe is more of a reference implementation,...

    softpipe is more of a reference implementation, simple codebase to follow. I'm using it to prototype ARB_gpu_shader_fp64 support where writing llvmpipe support would be a lot more work and...
  4. Replies
    9
    Views
    1,968

    it actually advertises GL 3.3 now, but you'd know...

    it actually advertises GL 3.3 now, but you'd know that if you read the commit msg. you had one job...
  5. yes totally reserving, its all hidden behind ...

    yes totally reserving, its all hidden behind

    yum install gnome-classic-session

    its been in Fedora longer than RHEL.
  6. Generally RH has budgets that have to be written...

    Generally RH has budgets that have to be written last year, and new hw is a real pain in the ass unless some customer or partner supplies it, especially monitors for some reason, nobody likes to give...
  7. I generally don't worry about problems I can't...

    I generally don't worry about problems I can't solve :-P, then the hw ends up on my desk, and its a problem I can solve!
  8. Replies
    6
    Views
    1,010

    Oh cool, thanks for letting me know, I just...

    Oh cool, thanks for letting me know, I just looked around the website to see it is now updated!, I might try and take a look at the project now :-)

    Dave.
  9. Replies
    6
    Views
    1,010

    ilo doesn't use lunarglass, nothing in the open...

    ilo doesn't use lunarglass, nothing in the open world does, for two reasons, they pulled a Qt/Canonical with the license, so its GPLv2 with copyright assignment so they can keep selling closed source...
  10. wow obvious bitter troll is obvious.

    wow obvious bitter troll is obvious.
  11. Replies
    76
    Views
    10,097

    just sent the r600/r700 support first pass. ...

    just sent the r600/r700 support first pass.

    also in the same branch in my repo.
  12. Replies
    76
    Views
    10,097

    focusing on older hardware takes a lot of time...

    focusing on older hardware takes a lot of time for not as much return, its just economics 101.

    The effort to fix DPM on r6xx is a lot harder than the effort to fix DPM support on r700 and so on...
  13. Replies
    76
    Views
    10,097

    no I had no idea AMD were working on radeonsi...

    no I had no idea AMD were working on radeonsi when I started this, Red Hat didn't have a need for it either, it was just a personal side-project that I did while avoiding doing my real job.

    I also...
  14. Replies
    76
    Views
    10,097

    he's just bitter fglrx doesn't work anymore :-) ...

    he's just bitter fglrx doesn't work anymore :-)

    but really not sure why he thinks I'd delay releasing evergreen code until r600 worked, seems like he's not used to open source development.

    I...
  15. Replies
    76
    Views
    10,097

    guess I should test with real apps instead of...

    guess I should test with real apps instead of piglit :-P

    Dave.
  16. It has two main problems, a) gpu hangs with...

    It has two main problems,

    a) gpu hangs with one or two tests left to track down

    b) doesn't work yet with r600g sb backend or llvm backends, the first is a stopper, the second I'm not sure I...
  17. Its not really a backporting type of situation...

    Its not really a backporting type of situation the hw is quite different, and the compiler is as well.

    Vadim started working on it and I've been fixing bugs in that code for a while, but its maybe...
  18. Replies
    6
    Views
    1,994

    just needs geometry shaders to get to 3.3 for...

    just needs geometry shaders to get to 3.3 for r600 -> cayman at least.

    Dave.
  19. why doesn't it? some apps can use extensions...

    why doesn't it? some apps can use extensions without the functionality level increase, though in some places the GLSL version increase is really important in others not so much.

    Also some...
  20. somewhere in the llvmpipe < virgl < native :-)...

    somewhere in the llvmpipe < virgl < native :-) hopefully. assuming native isn't llvmpipe!

    Dave.
Results 1 to 20 of 100
Page 1 of 5 1 2 3 4