Search:

Type: Posts; User: Fran; Keyword(s):

Page 1 of 5 1 2 3 4

Search: Search took 0.17 seconds.

  1. Replies
    6
    Views
    3,106

    I reinstalled my 3850 to see if it was just my...

    I reinstalled my 3850 to see if it was just my imagination. It wasn't.

    With the HD 3850 I get smooth scrolling in chromium, with or without composite. The Xorg process tops at 60% cpu usage when...
  2. Replies
    6
    Views
    3,106

    dmesg: http://pastebin.com/emWTaniA Xorg.0.log:...

    dmesg: http://pastebin.com/emWTaniA
    Xorg.0.log: http://pastebin.com/ZtpMScAw (ignore the 1.7.5.1 server version, it's 1.8.1. I've patched the version number to make it work with fglrx 10.4).

    The...
  3. Replies
    6
    Views
    3,106

    Bad 2D performance with HD 4200 (RS880)

    It's been a long time since I last played a game, so I decided to remove the HD 3850 from my computer and use the integrated HD 4200 instead (less heat and consumption, zero noise). However, the...
  4. Thread: r6xx 3D games

    by Fran
    Replies
    289
    Views
    71,709

    After recent updates Darwinia is very playable...

    After recent updates Darwinia is very playable (good framerate, only minor artifacts) and Doom 3, although with heavy shadow artifacts, has a decent framerate (30fps average in timedemo demo1).
    ...
  5. Replies
    2
    Views
    1,883

    Bad 2D performance with r600 [solved]

    Lately I'm experiencing a terrible 2D performance in VirtualBox and some other things (for example, the videos in NBA.com). Everything is unbearably choppy and the CPU usage is 100% in one core....
  6. Replies
    72
    Views
    31,812

    You're right. I don't know how, but I had an...

    You're right. I don't know how, but I had an ancient libdrm in /usr/local. Sorry for the noise.
  7. Replies
    72
    Views
    31,812

    I have the correct version of libdrm: $ nm -D...

    I have the correct version of libdrm:

    $ nm -D /usr/lib/libdrm.so.2.4.0 | grep Fd
    00000000000032c0 T drmGetDeviceNameFromFd

    but xf86-video-ati still refuses to install in gentoo:

    CC ...
  8. Thread: r6xx 3D games

    by Fran
    Replies
    289
    Views
    71,709

    It's the opposite. libdrm 2.4.14 is new enough....

    It's the opposite. libdrm 2.4.14 is new enough. ati 6.12.4 isn't (at least it doesn't work with KMS).

    I don't know about mesa.
  9. Thread: r6xx 3D games

    by Fran
    Replies
    289
    Views
    71,709

    That's the same bug I mentioned in quake3. Some...

    That's the same bug I mentioned in quake3. Some textures affixed to walls and floors (blood stains, shadows) are visible through walls. It also happens in neverball.

    It's been like this since the...
  10. Thread: r6xx 3D games

    by Fran
    Replies
    289
    Views
    71,709

    Hmmm... can you see players' shadows/floor stains...

    Hmmm... can you see players' shadows/floor stains through the walls in quake3 arena? Maybe that's also a mesa bug not specific to radeon hardware.
  11. Replies
    136
    Views
    46,587

    Yeah, it was solved when I synced this afternoon....

    Yeah, it was solved when I synced this afternoon.

    Now the only problem for me is the lack of suspend. Other than that it works well: stable and fast 2D and 3D.
  12. Replies
    136
    Views
    46,587

    No, it works built-in. I gave it a try by...

    No, it works built-in. I gave it a try by including the firmware blobs in the kernel binary and it boots (and X starts).

    @kernelOfTruth: those crashes are there for me too. They happen with...
  13. Replies
    136
    Views
    46,587

    Credit to taiu from irc :)

    Credit to taiu from irc :)
  14. Replies
    136
    Views
    46,587

    A make install should copy it for you. And...

    A make install should copy it for you. And modprobe radeon should load it.

    What I still haven't managed is to get it loaded when radeon is built-in. The boot process simply stops. If, as nanonyme...
  15. Replies
    136
    Views
    46,587

    Ok, I got it working. I just needed this patch...

    Ok, I got it working. I just needed this patch to solve the second issue.

    The third issue just went away.

    So right know I have KMS working perfectly in my r600, yay! \o/
  16. Replies
    136
    Views
    46,587

    Hum, maybe you're right. I thought that if ext4...

    Hum, maybe you're right. I thought that if ext4 support was built-in, the kernel should be able to locate the firmware in the root partition.

    I hate initrd :mad:

    Anyway, that's the least of my...
  17. Replies
    136
    Views
    46,587

    Doesn't work very well here (rv670, hd3850). As I...

    Doesn't work very well here (rv670, hd3850). As I said in the IRC:

    - If I enable modesetting by default at boot, it doesn't find the firmware (possibly my fault, because it *is* in...
  18. Replies
    83
    Views
    53,248

    Mine is more or less the same as RealNC's. This...

    Mine is more or less the same as RealNC's. This is the patch for the 9.8 ebuild.


    --- ati-drivers-9.8.ebuild 2009-09-04 17:09:49.000000000 +0200
    +++ ati-drivers-9.10.ebuild 2009-09-05...
  19. Replies
    83
    Views
    53,248

    I'm pretty sure everybody does; as Muad'Dib...

    I'm pretty sure everybody does; as Muad'Dib pointed out this is most probably caused by fglrx using 16-235 instead of 0-255 for each RGB component under xv.

    I seem to remember there was a registry...
  20. Replies
    83
    Views
    53,248

    I never filed a bug because for me it's SO...

    I never filed a bug because for me it's SO OBVIOUS that I assumed everybody knew and nobody cared / knew how to solve it. For example, I find it impossible to find a #000000 colored pixel with fglrx...
Results 1 to 20 of 100
Page 1 of 5 1 2 3 4