Obviously a workaround is to use the last working version of the driver. As I use gentoo I have a record of the last working version and can go back yo that - in my case ati-drivers-8.433.
I only...