My experience so far is that anything after 3.6.2 will not boot on a MacBook Pro9,1.

I'll try this tonight.