Search:

Type: Posts; User: marek; Keyword(s):

Page 1 of 5 1 2 3 4

Search: Search took 0.13 seconds.

  1. That's weird. What's your GPU and version of DRM?

    That's weird. What's your GPU and version of DRM?
  2. This is definitely a bug in nine. It shouldn't...

    This is definitely a bug in nine. It shouldn't bind vertex buffers to non-existent slots.
  3. What are the values of start_slot and count? The...

    What are the values of start_slot and count? The driver only supports 16 vertex buffers at the moment. You can try to increase SI_NUM_VERTEX_BUFFERS in si_state.h.
  4. AFAIK, AMD IL is only a shader...

    AFAIK, AMD IL is only a shader representation/language, it's not an API and as such cannot represent D3D9 states and draw commands. It's pretty useless by itself.
  5. Yes, that would work for proprietary drivers and...

    Yes, that would work for proprietary drivers and Intel, but it would probably be even slower than what wined3d is doing now.
  6. I recommend the latest branches from okias who...

    I recommend the latest branches from okias who seems to be maintaining it at the moment if you know how to build it (I don't).

    I personally don't like wined3d - it compiles shaders on demand,...
  7. Yes, kernel 3.15 and 3.16-rc has been unstable...

    Yes, kernel 3.15 and 3.16-rc has been unstable with Sea Islands chips. I think it should be fixed with latest drm-fixes-3.16 from here: http://cgit.freedesktop.org/~agd5f/linux

    If not, you can use...
  8. The workaround is enabled based on the name of...

    The workaround is enabled based on the name of the executable file being run. You must install Mesa's drirc for the workaround to be enabled. The bug was reported to Unigine some time ago, but...
  9. There are known hangs with kernel 3.15 on Sea...

    There are known hangs with kernel 3.15 on Sea Islands (confirmed on Bonaire, not sure about the other chips). A workaround is also known. We won't probably have a fix in time for 3.15 final, so...
  10. I think DirectX/3D is free to use on Windows...

    I think DirectX/3D is free to use on Windows only. I wouldn't be surprised if the license agreement for DirectX had this covered. Anyway, Wine isn't DirectX. The Nine state tracker isn't that either.
  11. We do have access to the hardware. The problem is...

    We do have access to the hardware. The problem is nobody knows why it doesn't work.
  12. Replies
    49
    Views
    13,363

    I'll have water. Thanks. :D

    I'll have water. Thanks. :D
  13. Replies
    18
    Views
    2,851

    Mesa checks the LLVM version at compile time, so...

    Mesa checks the LLVM version at compile time, so you need to install LLVM before you compile Mesa. Installing LLVM over old Mesa won't work.
  14. Replies
    18
    Views
    2,629

    That's not true. If a driver supports GLSL 3.30,...

    That's not true. If a driver supports GLSL 3.30, it also supports 1.50, 1.40, 1.30, 1.20, and 1.10. You can specify the GLSL version your shader is written for using the directive #version at the...
  15. Did he mean to say "A Few"? Saying just "Few...

    Did he mean to say "A Few"? Saying just "Few Linux Performance Improvements" sounds like bad news to me.
  16. It doesn't work on Bonaire. Everything is at 0%,...

    It doesn't work on Bonaire. Everything is at 0%, only VRAM seems to be correct.
  17. Replies
    33
    Views
    11,060

    People want it, but most people are not GPU...

    People want it, but most people are not GPU driver developers (or don't want to be). And those who are are too busy with other stuff.
  18. Replies
    33
    Views
    11,060

    In the long term, it doesn't make sense to use...

    In the long term, it doesn't make sense to use both LLVM and SB backends together, thus the option is not even considered. Both of them do a similar set of optimizations, and most importantly, the...
  19. Replies
    33
    Views
    11,060

    As far as I remember, the LLVM backend has always...

    As far as I remember, the LLVM backend has always been slower on R600 since Vadim's backend was merged. Why people think LLVM should be faster is a mystery to me.
  20. Replies
    18
    Views
    2,851

    Like I said, you need LLVM 3.5, not 3.4.x. 3.4.x...

    Like I said, you need LLVM 3.5, not 3.4.x. 3.4.x is just 3.4 with bug fixes.
Results 1 to 20 of 100
Page 1 of 5 1 2 3 4