Not yet. FreeBSD ships with a CentOS 6.7 userland that has an earlier version of glibc than required by steam....