tumbleweed was updated to gcc5 a year ago, and leap 42.1 was still built using 4.8.
i wonder if compatibility with SLES12.1 will force them to do...