What version it can read?

Because even Apple Page from 2013 can't read Page file from Page 3 & 4. It say that the file is too old..so...