First, ABI stands for Application Binary Interface. Second, the last time, gcc broke compatibility was the switch to gcc-4. This was in 2007. About glibc...