So, if you want Vulkan on linux, you need to buy a new GPU, even if yours is a 6 month old 400$ one. It's just very bad for customers.