Announcement

Collapse
No announcement yet.

ERROR: Copy of CD image failed

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ERROR: Copy of CD image failed

    Hi

    I tried to boot as single-user mode on my sunfire t1000 to change my root password since the guy has left the company without give us the root password.

    anyhow since this machine not have attached with cd/dvd/usb so the only think that to do it through Jumpstart

    now i tried to preparing my other machine sunfire v100 running solaris 9 as Jumpstart Server

    and i have download the image of of Solaris 10 Sparc .iso and following the bellow steps as mention it on other support forums/blogs

    # lofiadm -a sol-10-u11-ga-sparc-dvd.iso

    /dev/lofi/1
    # mount -o ro -F hsfs /dev/lofi/1 /mnt

    Now i have created the installation directory on the server:

    # mkdir -p /export/install


    # cd /mnt/Solaris_10/Tools

    # ./setup_install_server /export/install

    Verifying target directory...
    Calculating the required disk space for the Solaris_10 product
    Calculating space required for the installation boot image
    Copying the CD image to disk...
    ERROR: Copy of CD image failed


    so my issue stop here

    ERROR: Copy of CD image failed

    I have tried many different ways to solve this with no successful

    I add this
    set hsfs:nhsnode=4096 on /etc/system and reboot the machine since no error appear on /var/adm/messages for the same
    I also re download solaris image either CD or DVD.
    I have also check the disk space there is enough space on /export. Before i starting run the script

    I can't determine whats

    Any suggestions?

  • #2
    Originally posted by jmishal View Post
    Hi
    # cd /mnt/Solaris_10/Tools

    # ./setup_install_server /export/install

    Verifying target directory...
    Calculating the required disk space for the Solaris_10 product
    Calculating space required for the installation boot image
    Copying the CD image to disk...
    ERROR: Copy of CD image failed
    have you tried:

    # ./setup_install_server /export/install/solaris10

    It might well want a subdirectory to create the file into.

    Comment


    • #3
      issue fixed by

      Code:
      TMPDIR=/tmp 
      ./setup_install_server
      after i ran

      Code:
      truss -f ./setup_install_server /export/install >/tmp/truss.out 2>&1
      and read the error

      Comment


      • #4
        good to know you fixed it ... been several years since I last did it

        Comment

        Working...
        X