Announcement

Collapse
No announcement yet.

Connecting Forms 6i to local Oracle 8i

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Connecting Forms 6i to local Oracle 8i

    Hi,

    Good Morning,

    I am an educator teaching Oracle database and development classes at a small private college. I have Oracle 8i Enterprise installed on my local office machine (Win XP Pro) and then, since I was going to teach a class on Oracle 6i Forms Builder, I installed Forms Developer 6i on the same machine. I was able to see that Forms 6i messed up my Oracle_Home information in the registry and made it so neither worked. I got my database working again, but Forms will not connect to the database, and I'm sure there is got to be some fix to the registry settings to get Forms to see it's copy of the tnsnames file for connection. Anybody know what it is or how to fix forms (and/or Oracle 8i) to work with a local database instance? Any ideas or help would be appreciated, I've checked otn.oracle.com and all the help files I have access to and they are no help at all

    Regards

    Kenny Wylies

  • #2
    6i and 8i (~ year 2000)?

    wow, I've not seen them in a while.

    you need to install the designer and developer in their own Oracle_Home, you cannot install into the same Oracle_Home as the database, otherwise you get corruption, like you've experienced.

    You might need to de-install and re-install it into a different location.

    Can't you teach in something more modern? I remember installing this in Windows 95, meeting a bug and being advised to install in Windows 98 or NT to fix it!

    In the end we ditched the products completely and wrote everything in pl/sql htp/htf packages ... you'd be better off teaching ruby nowadays though.

    Jon

    Comment


    • #3
      That's a spam bot. See its other post: http://phoronix.com/forums/showthrea...Wireless-Cards

      Comment


      • #4
        Originally posted by curaga View Post
        That's a spam bot. See its other post: http://phoronix.com/forums/showthrea...Wireless-Cards
        Damn! they're getting cleverer.

        Seemed so like a badly informed question, I didn't even bother to tell them that this isn't a section for Oracle, but for Solaris

        Comment


        • #5
          Not Spam or Bot actual Human

          Originally posted by curaga View Post
          That's a spam bot. See its other post: http://phoronix.com/forums/showthrea...Wireless-Cards
          Dear Curage,

          not a spam its actual and human thinking unique create post.

          Regards


          Kenny,

          Comment


          • #6
            Originally posted by littlebird3450 View Post
            Dear Curage,

            not a spam its actual and human thinking unique create post.

            Regards


            Kenny,
            okay, do a database export on the database, de-install and remove everything from all the directories on the computer, install the database again, import your database and install designer and developer in a different Oracle_Home, or even a different computer.

            Seriously though, why are you trying to teach products that are older than my children?

            Comment

            Working...
            X